您的位置:首页 > 其它

Stockbroker Grapevine

2017-02-09 14:50 218 查看
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 35222Accepted: 19562
Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.
Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.
Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

Source

Southern African 2001
题目大意:

有N个股票经济人可以互相传递消息,他们之间存在一些单向的通信路径。
现在有一个消息要由某个人开始传递给其他所有人,问应该由哪一个人来传递,才能在最短时间内让所有人都接收到消息。
若不存在这样一个人,则输出disjoint。
N<=100.
(来自"Warrior、老师)
代码实现:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int n,m,a,b,now,ans,ant;
int map[110][110];
int main (){
while(scanf("%d",&n)){
if(!n) return 0;
ant=3000000;
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
map[i][j]=300000;
for(int i=1;i<=n;i++){
map[i][i]=0;
scanf("%d",&m);
for(int j=1;j<=m;j++){
scanf("%d%d",&a,&b);
map[i][a]=min(map[i][a],b);
}
}
for(int k=1;k<=n;k++)
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
map[i][j]=min(map[i][j],map[i][k]+map[k][j]);
for(int i=1;i<=n;i++){
now=0;
for(int j=1;j<=n;j++) now=max(now,map[i][j]);
if(now<ant){ans=i;ant=now;}
}
if(ant>30000) printf("disjoint\n");
else printf("%d %d\n",ans,ant);
}
}


题目来源:POJ
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: