您的位置:首页 > 其它

HDU 4432 因子之和以及进制转换问题

2017-01-22 20:38 567 查看
原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=4432


Sum of divisors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5161    Accepted Submission(s): 1725


Problem Description

mmm is learning division, she's so proud of herself that she can figure out the sum of all the divisors of numbers no larger than 100 within one day!

But her teacher said "What if I ask you to give not only the sum but the square-sums of all the divisors of numbers within hexadecimal number 100?" mmm get stuck and she's asking for your help.

Attention, because mmm has misunderstood teacher's words, you have to solve a problem that is a little bit different.

Here's the problem, given n, you are to calculate the square sums of the digits of all the divisors of n, under the base m.

 

Input

Multiple test cases, each test cases is one line with two integers.

n and m.(n, m would be given in 10-based)

1≤n≤109

2≤m≤16

There are less then 10 test cases.

 

Output

Output the answer base m.

 

Sample Input

10 2
30 5

 

Sample Output

110
112
Hint
Use A, B, C...... for 10, 11, 12......
Test case 1: divisors are 1, 2, 5, 10 which means 1, 10, 101, 1010 under base 2, the square sum of digits is
1^2+ (1^2 + 0^2) + (1^2 + 0^2 + 1^2) + .... = 6 = 110 under base 2.

题解:题目很简单,就是找出每个数的因子,我们可以从1开始到平方根结束,这样可以减少遍历,进制转换就可以用取余数加除法就行。最后对和进行进制转换就用一个字符数组存就行。

具体代码如下:

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 100000;
int factor[maxn]; /*存因子*/
char result[maxn];
int main() {
int n, m;
while (cin >> n >> m&&n&&m) {
int temp = sqrt(n);
int num = 0;
for (int i = 1;i <= temp;i++) { /*求出因子并保存*/
if (n%i == 0) {
factor[num++] = i;
if (i != n/i)
factor[num++] = n / i;
}
}
int sum = 0;
for (int i = 0;i < num;i++) {/*对每个因子进行处理*/
int tempFactor = factor[i];
while (tempFactor) {
sum += (tempFactor%m)*(tempFactor%m);
tempFactor /= m;
}
}
num = 0;
while (sum) { /*进制转换*/
int tempSum = sum%m;
if (tempSum < 10)
result[num++] = tempSum + '0';/*十进制以内转换*/
else
result[num++] = tempSum - 10 + 'A';/*十进制以上转换*/
sum /= m;
}
for (int i = num - 1;i >= 0;i--)
cout << result[i];
cout << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: