您的位置:首页 > 其它

PAT-甲级-1013

2017-01-17 21:18 148 查看


1013. Battle Over Cities (25)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities
connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is
occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow,
each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input
3 2 3
1 2
1 3
1 2 3

Sample Output
1
0
0

【解析】
给你n个城市,m条路,k个查询,就拿样例1来说吧,有三个城市编号是1,2,3,1有到2的路,1有到3的路,所以如果1被占领了,那就需要有2到3的路是没有的所以需要有一条路来连接。其实我们需要明白一个概念那就是在几个点当中看有几个连通分量,需要它们都连通的话,需要的路就是连通分量减一。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int a[1001][1001];
bool b[1001];
int n;
void dfs(int c)
{
b[c]=true;//已经访问过的点
int i;
for(i=1;i<=n;i++)
{
if(b[i]==false&&a[c][i]==1)//表示是连通的但没有访问
dfs(i);
}
}
int main()
{
int m,k,p,q,i,count1,j;
scanf("%d%d%d",&n,&m,&k);
for(i=0;i<m;i++)
{
scanf("%d%d",&p,&q);
a[p][q]=a[q][p]=1;//表示相通的路
}
for(i=0;i<k;i++)
{
count1=0;
scanf("%d",&p);
fill(b,b+1001,false);
b[p]=true;//设置这个被占领的点已经访问过的
for(j=1;j<=n;j++)
{
if(b[j]==false)//表示这个点没有访问过进行访问
{
dfs(j);
count1++;
}
}
printf("%d\n",count1-1);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: