您的位置:首页 > 其它

PAT(甲级)1013

2015-09-23 16:35 393 查看


1013. Battle Over Cities (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities
connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is
occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow,
each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.
Sample Input
3 2 3
1 2
1 3
1 2 3

Sample Output
1
0
0
#include <iostream>
#include <vector>
#define SIZE 1003

using namespace std;

struct Node{
Node(int i){
number = i;
Next = NULL;
}
int number;
Node *Next;
};

struct City{
// int number;
City(){
visited = false;
flag = false;
Next = NULL;
}
bool visited;
bool flag;
Node *Next;
Node *last;
void AddNode(int i);
};

void City::AddNode(int i){
if(last != NULL){
last->Next = new Node(i);
last = last->Next;
}else{
Next = new Node(i);
last = Next;
}
}

City C[SIZE];

void DFS(City C[],int &rootnumber){
City *pcity = &C[rootnumber];
pcity->visited = true;
Node *pNode = pcity->Next;
while(pNode != NULL){
int number = pNode->number;
if(!C[number].visited && !C[number].flag)
DFS(C,pNode->number);
pNode = pNode->Next;
}
}

void Reset(City C[], int n){
for(int i = 1;i<=n;i++){
C[i].visited = false;
C[i].flag = false;
}
}

void Display(City C[],int N)
{
for(int i=1;i<N;i++){
cout <<i <<' ';
City *pcity = &C[i];
Node *pNode = pcity->Next;
while(pNode != NULL){
cout <<pNode->number <<' ';
pNode = pNode->Next;
}
cout <<endl;
}
}

int main()
{
int N,M,K;
int c1,c2;
// freopen("test.txt","r",stdin);
scanf("%d%d%d",&N,&M,&K);
for(int i=1;i<=M;i++){
scanf("%d%d",&c1,&c2);
C[c1].AddNode(c2);
C[c2].AddNode(c1);
}
// Display(C,N);
for(int i=0;i<K;i++){
scanf("%d",&c1);
Reset(C,N);
C[c1].flag = true;
int count = 0;
for(int j=1;j<=N;j++){
if(C[j].flag)
continue;
else{
if(!C[j].visited){
count++;
DFS(C,j);
}
}
}
printf("%d\n",count-1);
}
// fclose(stdin);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: