您的位置:首页 > 其它

POJ2488 A Knight's Journey(深搜DFS,字典序,骑士游历问题)

2017-01-07 17:35 543 查看
题目:

A Knight's Journey

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 42989 Accepted: 14597
Description


Background 

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 

around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board,
but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes
how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves
followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 

If no such path exist, you should output impossible on a single line.
Sample Input
3
1 1
2 3
4 3

Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany
[Submit]   [Go Back]   [Status]  
[Discuss]
思路:
这道题的坑点在于字典序,一定要按照字典序进行搜索

代码;

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
int go[8][2]= {{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};//字典序方向
int vis[30][30];
int n,m,fl
ea16
ag;
struct node
{
int x,y;
} a[30]; //存储每一步的坐标
void dfs(int x,int y,int step)
{
a[step].x=x,a[step].y=y;//把当前路径存入结构体
if(step==n*m)//搜完每一个格子打印路径
{
for(int i=1; i<=step; i++)
printf("%c%d",a[i].y-1+'A',a[i].x);//打印路径
printf("\n");
flag=1;
}
if(flag)return;
for(int i=0; i<8; i++)
{
int xx=x+go[i][0];
int yy=y+go[i][1];
if(xx>0&&xx<=n&&yy>0&&yy<=m&&vis[xx][yy]==0)//判断是否越界
{
vis[xx][yy]=1;//搜过的标记
dfs(xx,yy,step+1);
vis[xx][yy]=0;//标记回来
}
}
}
int main()
{
int t,ci=1;
scanf("%d",&t);
while(t--)
{
mem(vis,0);
flag=0;
scanf("%d%d",&n,&m);
printf("Scenario #%d:\n",ci++);
vis[1][1]=1;//先把第一个坐标标记了
dfs(1,1,1);//从(1,1)开始搜索
if(flag==0)printf("impossible\n");
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: