您的位置:首页 > 其它

4-7 在一个数组中实现两个堆栈 (20分)

2016-12-17 23:24 417 查看
本题要求在一个数组中实现两个堆栈。 

函数接口定义:

Stack CreateStack( int MaxSize ); 

bool Push( Stack S, ElementType X, int Tag ); 

ElementType Pop( Stack S, int Tag );

其中Tag是堆栈编号,取1或2;MaxSize堆栈数组的规模;Stack结构定义如下:

typedef int Position; 

struct SNode { 

ElementType *Data; 

Position Top1, Top2; 

int MaxSize; 

}; 

typedef struct SNode *Stack;

注意:如果堆栈已满,Push函数必须输出“Stack Full”并且返回false;如果某堆栈是空的,则Pop函数必须输出“Stack Tag Empty”(其中Tag是该堆栈的编号),并且返回ERROR。 

裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>

#define ERROR 1e8
typedef int ElementType;
typedef enum { push, pop, end } Operation;
typedef enum { false, true } bool;
typedef int Position;
struct SNode {
ElementType *Data;
Position Top1, Top2;
int MaxSize;
};
typedef struct SNode *Stack;

Stack CreateStack( int MaxSize );
bool Push( Stack S, ElementType X, int Tag );
ElementType Pop( Stack S, int Tag );

Operation GetOp();  /* details omitted */
void PrintStack( Stack S, int Tag ); /* details omitted */

int main()
{
int N, Tag, X;
Stack S;
int done = 0;

scanf("%d", &N);
S = CreateStack(N);
while ( !done ) {
switch( GetOp() ) {
case push:
scanf("%d %d", &Tag, &X);
if (!Push(S, X, Tag)) printf("Stack %d is Full!\n", Tag);
break;
case pop:
scanf("%d", &Tag);
X = Pop(S, Tag);
if ( X==ERROR ) printf("Stack %d is Empty!\n", Tag);
break;
case end:
PrintStack(S, 1);
PrintStack(S, 2);
done = 1;
break;
}
}
return 0;
}

/* 你的代码将被嵌在这里 */
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52

输入样例:



Push 1 1 

Pop 2 

Push 2 11 

Push 1 2 

Push 2 12 

Pop 1 

Push 2 13 

Push 2 14 

Push 1 3 

Pop 2 

End

输出样例:

Stack 2 Empty 
Stack 2 is Empty! 
Stack Full 
Stack 1 is Full! 
Pop from Stack 1: 1 

Pop from Stack 2: 13 12 11
代码实现如下:

Stack CreateStack( int MaxSize )

{

    ElementType element[MaxSize];

    Stack stack = (Stack)malloc(sizeof(struct SNode));

   //注意数组需要动态分配,之前犯得错误为  ElementType a[MaxSize];
 stack->Data  = a;

    stack->Data = (ElementType*)malloc(sizeof(ElementType)*MaxSize);

    stack->Top1 = -1;

    stack->Top2 = MaxSize;

    stack->MaxSize = MaxSize;

    return stack;

}

bool Push( Stack S, ElementType X, int Tag )

{

    if(S->Top1+1==S->Top2)

    {

        printf("Stack Full\n");

        return false;

    }

    if(Tag == 1)

    {

        S->Top1++;

        S->Data[S->Top1] = X;

        return true;

    }

    else

    {

        S->Top2--;

        S->Data[S->Top2] = X;

        return true;

    }

    return false;

}

ElementType Pop( Stack S, int Tag )

{

    if(Tag==1)

    {

        if(S->Top1 == 0)

        {

            printf("Stack %d Empty\n",Tag);

            return ERROR;

        }

        S->Top1--;

        return S->Data[S->Top1+1];

    }

    else

    {

        if(S->Top2 == S->MaxSize)

        {

            printf("Stack %d Empty\n",Tag);

            return ERROR;

        }

        S->Top2++;

        return S->Data[S->Top2-1];

    }

}

ElementType Pop( Stack S, int Tag ){

    if(S == NULL)

        return ERROR;

    if(1 == Tag){

        if(-1 == S->Top1){

            printf("Stack %d Empty\n", Tag);

            return ERROR;

        }

        return S->Data[(S->Top1)--];    

    }else if(2 == Tag){

        if(S->MaxSize == S->Top2){

            printf("Stack %d Empty\n", Tag);

            return ERROR;

        }

        return S->Data[(S->Top2)++];    

    }

    return ERROR;

}

Operation GetOp() 

{

    char a[5];

    scanf("%s",a);

    if(strcmp(a,"push")==0) return push;

    if(strcmp(a,"pop")==0) return pop;

    if(strcmp(a,"end")==0) return end;

}

void PrintStack( Stack S, int Tag )

{

    if(Tag==1)

    {

       printf("Pop from Stack 1:") ;

       for(int i =S->Top1;i>=0;i--)

        printf("%d ",(S->Data)[i]);

        printf("\n");

    }

     if(Tag==2)

    {

       printf("Pop from Stack 2:") ;

       for(int i = S->Top2;i<S->MaxSize;i++)

        printf("%d ",(S->Data)[i]);

    }

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: