您的位置:首页 > 其它

4-7 在一个数组中实现两个堆栈 (20分)

2016-07-11 19:12 453 查看
本题要求在一个数组中实现两个堆栈。

函数接口定义:

Stack CreateStack( int MaxSize );

bool Push( Stack S, ElementType X, int Tag );

ElementType Pop( Stack S, int Tag );

其中Tag是堆栈编号,取1或2;MaxSize堆栈数组的规模;Stack结构定义如下:

typedef int Position;

struct SNode {

ElementType *Data;

Position Top1, Top2;

int MaxSize;

};

typedef struct SNode *Stack;

注意:如果堆栈已满,Push函数必须输出“Stack Full”并且返回false;如果某堆栈是空的,则Pop函数必须输出“Stack Tag Empty”(其中Tag是该堆栈的编号),并且返回ERROR。

裁判测试程序样例:

#include <stdio.h>
#include <stdlib.h>

#define ERROR 1e8
typedef int ElementType;
typedef enum { push, pop, end } Operation;
typedef enum { false, true } bool;
typedef int Position;
struct SNode {
ElementType *Data;
Position Top1, Top2;
int MaxSize;
};
typedef struct SNode *Stack;

Stack CreateStack( int MaxSize );
bool Push( Stack S, ElementType X, int Tag );
ElementType Pop( Stack S, int Tag );

Operation GetOp();  /* details omitted */
void PrintStack( Stack S, int Tag ); /* details omitted */

int main()
{
int N, Tag, X;
Stack S;
int done = 0;

scanf("%d", &N);
S = CreateStack(N);
while ( !done ) {
switch( GetOp() ) {
case push:
scanf("%d %d", &Tag, &X);
if (!Push(S, X, Tag)) printf("Stack %d is Full!\n", Tag);
break;
case pop:
scanf("%d", &Tag);
X = Pop(S, Tag);
if ( X==ERROR ) printf("Stack %d is Empty!\n", Tag);
break;
case end:
PrintStack(S, 1);
PrintStack(S, 2);
done = 1;
break;
}
}
return 0;
}

/* 你的代码将被嵌在这里 */


输入样例:

5

Push 1 1

Pop 2

Push 2 11

Push 1 2

Push 2 12

Pop 1

Push 2 13

Push 2 14

Push 1 3

Pop 2

End

输出样例:

Stack 2 Empty

Stack 2 is Empty!

Stack Full

Stack 1 is Full!

Pop from Stack 1: 1

Pop from Stack 2: 13 12 11

#include <stdio.h>
#include <stdlib.h>

#define ERROR 1e8
typedef int ElementType;
typedef enum { push, pop, end } Operation;
typedef enum { false, true } bool;
typedef int Position;
struct SNode {
ElementType *Data;
Position Top1, Top2;
int MaxSize;
};
typedef struct SNode *Stack;

Stack CreateStack( int MaxSize );
bool Push( Stack S, ElementType X, int Tag );
ElementType Pop( Stack S, int Tag );

Operation GetOp(){
char a[5];
scanf("%s",a);
if(strcmp(a,"Push")==0) return push;
if(strcmp(a,"Pop")==0) return pop;
if(strcmp(a,"End")==0) return end;
}
void PrintStack( Stack S, int Tag ){
if(Tag==1){
printf("Pop from Stack %d: ",Tag);
while((S->Top1)!=-1){
printf("%d ",S->Data[(S->Top1)--]);
}
putchar('\n');
}else{
printf("Pop from Stack %d: ",Tag);
while((S->Top2)!=S->MaxSize){
printf("%d ",S->Data[(S->Top2)++]);
}
putchar('\n');
}
}
int main()
{
int N, Tag, X;
Stack S;
int done = 0;

scanf("%d", &N);
S = CreateStack(N);
while ( !done ) {
switch( GetOp() ) {
case push:
scanf("%d %d", &Tag, &X);
if (!Push(S, X, Tag)) printf("Stack %d is Full!\n", Tag);
break;
case pop:
scanf("%d", &Tag);
X = Pop(S, Tag);
if ( X==ERROR ) printf("Stack %d is Empty!\n", Tag);
break;
case end:
PrintStack(S, 1);
PrintStack(S, 2);
done = 1;
break;
}
}
return 0;
}
Stack CreateStack( int MaxSize ){
Stack S = (Stack)malloc(sizeof(struct SNode));
S->MaxSize = MaxSize;
S->Data = (ElementType *)malloc(sizeof(ElementType)*MaxSize);
S->Top2 = MaxSize;
S->Top1 = -1;
return S;
}
bool Push( Stack S, ElementType X, int Tag ){
if(S == NULL)
return false;
if((S->Top1 + 1) == S->Top2){
printf("Stack Full\n");
return false;
}
if(1 == Tag){
S->Data[++(S->Top1)] = X;
return true;
}
else if (2 == Tag){
S->Data[(--S->Top2)] = X;
return true;
}
return false;
}
ElementType Pop( Stack S, int Tag ){
if(S == NULL)
return ERROR;
if(1 == Tag){
if(-1 == S->Top1){
printf("Stack %d Empty\n", Tag);
return ERROR;
}
return S->Data[(S->Top1)--];
}else if(2 == Tag){
if(S->MaxSize == S->Top2){
printf("Stack %d Empty\n", Tag);
return ERROR;
}
return S->Data[(S->Top2)++];
}
return ERROR;
}


题目链接:

https://pta.patest.cn/pta/test/15/exam/3/question/730
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: