您的位置:首页 > 其它

文章标题 POJ 3278 : Catch That Cow(BFS)

2016-11-13 20:08 459 查看

Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意:John想尽快找到逃跑的牛,已知牛的位置k一直没有改变,而John每次可以往三个位置移动,当前位置为x时,下一次可以到x+1,x-1,x*2,问最少John最少需要多少时间到牛的位置。

分析:BFS,从x开始,往三个方向移动,如果是k就输出到达此点的时间,此时到达k时就是最短的时间,如果不是k就将此数放进队列。

代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<vector>
#include<math.h>
#include<map>
#include<queue>
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
int n,k;
struct node {//结构体,位置和到达该位置的最短步数
int x,step;
};
node a[100005];
int flag[100005];
int bfs(int n){
for (int i=0;i<=100000;i++){
a[i].x=i;
a[i].step=inf;
}
memset(flag,0,sizeof (flag));
flag
=1;
a
.x=n;
a
.step=0;
queue <node> q;
q.push(a
);
int ans=0;
while (!q.empty()){
node tmp=q.front();
q.pop();
if (tmp.x==k){//判断是不是x是返回答案
ans=tmp.step;
return ans;
}
if (tmp.x-1>=0&&tmp.x-1<=100000&&!flag[tmp.x-1]){//判断是否在范围内,是的话就放进队列
node t; t.x=tmp.x-1; t.step=tmp.step+1; flag[tmp.x-1]=1;
q.push(t);
}
if (tmp.x+1>=0&&tmp.x+1<=100000&&!flag[tmp.x+1]){
node t; t.x=tmp.x+1; t.step=tmp.step+1; flag[tmp.x+1]=1;
q.push(t);
}
if (tmp.x*2>=0&&tmp.x*2<=100000&&!flag[tmp.x*2]){
node t; t.x=tmp.x*2; t.step=tmp.step+1; flag[tmp.x*2]=1;
q.push(t);
}
}
return -1;
}
int main ()
{
while (scanf ("%d%d",&n,&k)!=EOF){
int ans=bfs(n);//得到答案
printf ("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  bfs poj