您的位置:首页 > 其它

POJ 3278 Catch That Cow(BFS)

2018-03-05 22:27 411 查看
题目链接:http://poj.org/problem?id=3278
题目大意:给定n和k,农夫在n位置,奶牛在k位置,奶牛不动,农夫只有三种走法,+1,-1,*2,问最短时间抓到奶牛
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
InputLine 1: Two space-separated integers: N and KOutputLine 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.Sample Input5 17Sample Output4题目思路:最短路径,BFS,当k<=n时,只能一直减,答案是n-k,否则用BFS求最短,记得标记已经访问过的点
代码:#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<queue>
#include<stack>

using namespace std;

#define FOU(i,x,y) for(int i=x;i<=y;i++)
#define FOD(i,x,y) for(int i=x;i>=y;i--)
#define MEM(a,val) memset(a,val,sizeof(a))
#define PI acos(-1.0)

const double EXP = 1e-9;
typedef long long ll;
typedef unsigned long long ull;
const int INF = 0x3f3f3f3f;
const ll MINF = 0x3f3f3f3f3f3f3f3f;
const int mod = 1e9+7;
const int N = 2e5+5;

int n,k;
int vis
;

struct node
{
int x,step;
}a,next;

bool check(int x)
{
if(x<0||x>N||vis[x]==1)
return false;
return true;
}

int bfs()
{
queue<node>q;
a.x=n;
a.step=0;
vis[a.x]=1;
q.push(a);
while(!q.empty())
{
a=q.front();
q.pop();
if(a.x==k)
return a.step;
next.x=a.x*2;
next.step=a.step+1;
if(check(next.x))
{
vis[next.x]=1;
q.push(next);
}
next.x=a.x+1;
next.step=a.step+1;
if(check(next.x))
{
vis[next.x]=1;
q.push(next);
}
next.x=a.x-1;
next.step=a.step+1;
if(check(next.x))
{
vis[next.x]=1;
q.push(next);
}
}
}

int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
std::ios::sync_with_stdio(false);

while(~scanf("%d%d",&n,&k))
{
if(k<=n)
printf("%d\n",n-k);
else
{
MEM(vis,0);
printf("%d\n",bfs());
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  BFS POJ