您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验图论一:基于邻接矩阵的广度优先搜索遍历

2016-11-09 11:32 387 查看


数据结构实验图论一:基于邻接矩阵的广度优先搜索遍历

Time Limit: 1000MS Memory Limit: 65536KB
[align=center]Submit Statistic[/align]


Problem Description

给定一个无向连通图,顶点编号从0到n-1,用广度优先搜索(BFS)遍历,输出从某个顶点出发的遍历序列。(同一个结点的同层邻接点,节点编号小的优先遍历)


Input

输入第一行为整数n(0< n <100),表示数据的组数。

对于每组数据,第一行是三个整数k,m,t(0<k<100,0<m<(k-1)*k/2,0< t<k),表示有m条边,k个顶点,t为遍历的起始顶点。

下面的m行,每行是空格隔开的两个整数u,v,表示一条连接u,v顶点的无向边。


Output

输出有n行,对应n组输出,每行为用空格隔开的k个整数,对应一组数据,表示BFS的遍历结果。


Example Input

1
6 7 0
0 3
0 4
1 4
1 5
2 3
2 4
3 5



Example Output

0 3 4 2 5 1



Hint

以邻接矩阵作为存储结构。


Author

 

SDUTACM运维技术中心

Copyright © 2013-2014 SDUTACM Team. All Rights Reserved.

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
int n, m, s;
bool map[100+5][100+5];
int main() {
int t;
scanf("%d", &t);
while(t--) {
memset(map,0,sizeof(map));
scanf("%d %d %d", &n, &m, &s);
while(m--) {
int u, v;
scanf("%d %d", &u, &v);
map[u][v]=map[v][u]=1;
}
queue<int > q;
q.push(s);
bool vis[100+5]={0}, first=1;
vis[s]=1;
while(!q.empty()) {
int x=q.front();
if(!first) printf(" ");
first=0;
printf("%d", x);
q.pop();
for(int i=0;i<n;i++)
if(map[x][i]&&!vis[i]) {
vis[i]=1;
q.push(i);
}
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐