您的位置:首页 > Web前端

bzoj 3942: [Usaco2015 Feb]Censoring (kmp)

2016-11-07 17:18 141 查看

3942: [Usaco2015 Feb]Censoring

Time Limit: 10 Sec  Memory Limit: 128 MB
Submit: 314  Solved: 174

[Submit][Status][Discuss]

Description

Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest issue contains a rather inappropriate article on
how to cook the perfect steak, which FJ would rather his cows not see (clearly, the magazine is in need of better editorial oversight).

FJ has taken all of the text from the magazine to create the string S of length at most 10^6 characters. From this, he would like to remove occurrences of a substring T to censor the inappropriate content. To do this, Farmer John finds the _first_ occurrence
of T in S and deletes it. He then repeats the process again, deleting the first occurrence of T again, continuing until there are no more occurrences of T in S. Note that the deletion of one occurrence might create a new occurrence of T that didn't exist before.

Please help FJ determine the final contents of S after censoring is complete

有一个S串和一个T串,长度均小于1,000,000,设当前串为U串,然后从前往后枚举S串一个字符一个字符往U串里添加,若U串后缀为T,则去掉这个后缀继续流程。


Input

The first line will contain S. The second line will contain T. The length of T will be at most that of
S, and all characters of S and T will be lower-case alphabet characters (in the range a..z).



Output


The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.



Sample Input

whatthemomooofun

moo

Sample Output

whatthefun

HINT

Source

Silver

[Submit][Status][Discuss]

题解:kmp

失配其实就是最长后缀等于前缀的长度。

先说明一下,kmp在求失配函数的时候,字符串是从0开始存的,但是失配是从1开始存的。

也就是第0位的失配存在t[1]中。

这道题我可以将第二个串接到第一个串的前面,并加入一个分割符。然后求失配,当一个点的失配恰好等于第二个串的长度时,就把记录答案的栈的首指针-len2。正常求失配的时候我用的是i推i+1,但是这个牵扯到删去一段,所以是用删去后的st[top]来更新当前的答案。注意不要把开头的第二个串也删掉。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#define N 2000003
using namespace std;
int n,m,t
,a
,top,st
,st1
,len,len1;
char s
,s1
;
void calc()
{
t[0]=-1; int j;
int i=0; int last=i;
while (i<n) {
st[++top]=a[i]; st1[top]=i+1;
j=t[last];
while(j!=-1&&a[i]!=a[j]) j=t[j];
t[i+1]=++j;
if(t[i+1]==len1&&top-len1>=len1) top-=len1;
last=st1[top];
i++;
}
}
int main()
{
freopen("a.in","r",stdin);
freopen("my.out","w",stdout);
scanf("%s",s); scanf("%s",s1);
//cout<<s<<endl; cout<<s1<<endl;
len1=strlen(s1);
for (int i=0;i<len1;i++) a[i]=s1[i];
len=strlen(s);
a[len1]=0;
for (int i=0;i<len;i++) a[len1+i+1]=s[i];
n=len+len1+1;
//for (int i=0;i<n;i++) printf("%c",a[i]);
//cout<<endl;
calc();
for (int i=len1+2;i<=top;i++) printf("%c",st[i]);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: