您的位置:首页 > 其它

hdu 2444 The Accomodation of Students (二分图判定+匈牙利算法)

2016-11-09 16:08 183 查看

The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5566    Accepted Submission(s): 2539


[align=left]Problem Description[/align]
There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only
paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

 

[align=left]Input[/align]
For each data set:

The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

[align=left]Output[/align]
If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.

 

[align=left]Sample Input[/align]

4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6

 

[align=left]Sample Output[/align]

No
3

 

[align=left]Source[/align]
2008 Asia Harbin Regional Contest Online

 

[align=left]Recommend[/align]
gaojie   |   We have carefully selected several similar problems for you:  2438 2443 2442 2441 2440 
 

Statistic | Submit | Discuss
| Note

题解:二分图判定+匈牙利算法。

对图进行黑白染色(一条边的两个端点颜色必须不同),如果一个点被染了两种颜色,那么一定不是二分图。

匈牙利算法用来计算二分图的最大匹配,时间复杂度O(ve)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define N 403
using namespace std;
int point
,nxt[N*N],v[N*N];
int belong
,cur
,n,m,vis
,col
,tot;
bool pd;
void add(int x,int y)
{
tot++; nxt[tot]=point[x]; point[x]=tot; v[tot]=y;
tot++; nxt[tot]=point[y]; point[y]=tot; v[tot]=x;
}
void dfs(int x,int mark)
{
col[x]=mark;
for (int i=point[x];i;i=nxt[i])
{
if (col[v[i]]==-1) dfs(v[i],mark^1);
else if (col[v[i]]!=mark^1) {
pd=false;
return;
}
}
}
bool find(int x,int k)
{
for (int i=point[x];i;i=nxt[i])
{
if (cur[v[i]]==k) continue;
cur[v[i]]=k;
if(!belong[v[i]]||find(belong[v[i]],k)) {
belong[v[i]]=x;
return true;
}
}
return false;
}
int main()
{
while (scanf("%d%d",&n,&m)!=EOF) {
tot=0;
if (n==1) {
printf("No");
continue;
}
memset(nxt,0,sizeof(nxt));
memset(point,0,sizeof(point));
for (int i=1;i<=m;i++) {
int x,y; scanf("%d%d",&x,&y);
add(x,y);
}
memset(belong,0,sizeof(belong));
memset(vis,0,sizeof(vis));
memset(cur,0,sizeof(cur)); pd=true;
memset(col,-1,sizeof(col));
for (int i=1;i<=n;i++)
if (col[i]==-1) dfs(i,0);
if (!pd) {
printf("No\n");
continue;
}
int ans=0;
for (int i=1;i<=n;i++)
if (find(i,i)) ans++;
printf("%d\n",ans/2);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐