您的位置:首页 > 其它

【POJ 3070 Fibonacci】+ 矩阵快速幂

2016-11-06 18:29 363 查看
Fibonacci

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 13752 Accepted: 9742

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.


Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0

9

999999999

1000000000

-1

Sample Output

0

34

626

6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.


矩阵都给来了~~~直接算~~矩阵还是很好用的~~一个快速计算卡特兰序列的方法~~

AC代码 :

#include<cstdio>
#include<algorithm>
using namespace std;
const int mod = 10000;
struct node{
int m[2][2];
}dw,ans;
node jz(node a,node b){ // 矩阵构造
node sum;
for(int i = 0 ; i < 2 ; i++)
for(int j = 0 ; j < 2 ; j++){
sum.m[i][j] = 0;
for(int k = 0 ; k < 2 ; k++)
sum.m[i][j] = (sum.m[i][j] + a.m[i][k] * b.m[k][j]) % mod;
}
return sum;
}
int solve(int n){ // 矩阵快速幂
dw.m[0][0] = dw.m[1][1] = 1;
dw.m[0][1] = dw.m[1][0] = ans.m[1][1] = 0;
ans.m[0][0] = ans.m[0][1] = ans.m[1][0] = 1;
while(n){
if(n & 1)
dw = jz(dw,ans);
ans = jz(ans,ans);
n >>= 1;
}
return dw.m[0][1];
}
int main()
{
int N;
while(scanf("%d",&N) != EOF && N != - 1){
printf("%d\n",solve(N));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: