您的位置:首页 > 其它

POJ 2823 Sliding Window 单调队列

2016-11-01 10:22 537 查看
Sliding Window

Time Limit: 12000MSMemory Limit: 65536K
Total Submissions: 55893Accepted: 16072
Case Time Limit: 5000MS
DescriptionAn array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:

The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window positionMinimum valueMaximum value
[1 3 -1] -3 5 3 6 7 -13
1 [3 -1 -3] 5 3 6 7 -33
1 3 [-1 -3 5] 3 6 7 -35
1 3 -1 [-3 5 3] 6 7 -35
1 3 -1 -3 [5 3 6] 7 36
1 3 -1 -3 5 [3 6 7]37
Your task is to determine the maximum and minimum values in the sliding window at each position.

InputThe input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

OutputThere are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input8 3
1 3 -1 -3 5 3 6 7
Sample Output-1 -3 -3 -3 3 3
3 3 5 5 6 7
SourcePOJ Monthly–2006.04.28, Ikki

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int SZ = 1000010;

struct Queue
{
int v, pos;
}Q[SZ];
int num[SZ], n, k, Min[SZ], Max[SZ];

int read()
{
int num = 0, f = 1; char c = getchar();
while(c < '0' || c > '9'){if(c == '-') f = -1; c = getchar();}
while('0' <= c && c <= '9'){num = num * 10 + (c - '0'); c = getchar();}
return num * f;
}

void get_min()
{
int head = 1, tail = 0, cnt = 0;
for(int i = 1; i < k; i++)
{
while(head <= tail && Q[tail].v > num[i]) tail--;
tail++;
Q[tail].v = num[i];
Q[tail].pos = i;
}
for(int i = k; i <= n; i++)
{
while(head <= tail && Q[tail].v > num[i]) tail--;
tail++;
Q[tail].v = num[i];
Q[tail].pos = i;
while(i - Q[head].pos >= k) head++;
Min[++cnt] = Q[head].v;
}
}

void get_max()
{
int head = 1, tail = 0, cnt = 0;
for(int i = 1; i < k; i++)
{
while(head <= tail && Q[tail].v < num[i]) tail--;
tail++;
Q[tail].v = num[i];
Q[tail].pos = i;
}
for(int i = k; i <= n; i++)
{
while(head <= tail && Q[tail].v < num[i]) tail--;
tail++;
Q[tail].v = num[i];
Q[tail].pos = i;
while(i - Q[head].pos >= k) head++;
Max[++cnt] = Q[head].v;
}
}

int main()
{
while(~scanf("%d%d", &n, &k))
{
for(int i = 1; i <= n; i++)
num[i] = read();
get_min();
memset(Q, 0, sizeof(Q));
get_max();
int end =  n - k + 1;
for(int i = 1; i <= end; i++) printf("%d%c", Min[i], i == end ? '\n' : ' ');
for(int i = 1; i <= end; i++) printf("%d%c", Max[i], i == end ? '\n' : ' ');
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ 单调队列