您的位置:首页 > 产品设计 > UI/UE

hdu 5950 Recursive sequence 矩阵快速幂

2016-10-31 20:40 525 查看

Recursive sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

[align=left]Problem Description[/align]
Farmer
John likes to play mathematics games with his N cows. Recently, they
are attracted by recursive sequences. In each turn, the cows would stand
in a line, while John writes two positive numbers a and b on a
blackboard. And then, the cows would say their identity number one by
one. The first cow says the first number a and the second says the
second number b. After that, the i-th cow says the sum of twice the
(i-2)-th number, the (i-1)-th number, and i4. Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right.

[align=left]Input[/align]
The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b < 231 as described above.

[align=left]Output[/align]
For
each test case, output the number of the N-th cow. This number might be
very large, so you need to output it modulo 2147493647.

[align=left]Sample Input[/align]

2
3 1 2
4 1 10

[align=left]Sample Output[/align]

85
369

Hint

In the first case, the third number is 85 = 2*1十2十3^4.
In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.

[align=left]Source[/align]
2016ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学)
  套板子,取模开ll就好了;

#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define pi (4*atan(1.0))
#define eps 1e-14
const int N=2e5+10,M=1e6+10,inf=1e9+10;
const ll INF=1e18+10,MOD=2147493647;
struct Matrix
{
ll a[10][10];
Matrix()
{
memset(a,0,sizeof(a));
}
void init()
{
for(int i=0;i<7;i++)
for(int j=0;j<7;j++)
a[i][j]=(i==j);
}
Matrix operator + (const Matrix &B)const
{
Matrix C;
for(int i=0;i<7;i++)
for(int j=0;j<7;j++)
C.a[i][j]=(a[i][j]+B.a[i][j])%MOD;
return C;
}
Matrix operator * (const Matrix &B)const
{
Matrix C;
for(int i=0;i<7;i++)
for(int k=0;k<7;k++)
for(int j=0;j<7;j++)
C.a[i][j]=(C.a[i][j]+(a[i][k]*B.a[k][j])%MOD)%MOD;
return C;
}
Matrix operator ^ (const ll &t)const
{
Matrix A=(*this),res;
res.init();
int p=t;
while(p)
{
if(p&1)res=res*A;
A=A*A;
p>>=1;
}
return res;
}
};
Matrix base,hh;
void init()
{
base.a[0][0]=1;
base.a[1][0]=2;
base.a[2][0]=1;
base.a[0][1]=1;
base.a[2][2]=1;
base.a[3][2]=4;
base.a[4][2]=6;
base.a[5][2]=4;
base.a[6][2]=1;
base.a[3][3]=1;
base.a[4][3]=3;
base.a[5][3]=3;
base.a[6][3]=1;
base.a[4][4]=1;
base.a[5][4]=2;
base.a[6][4]=1;
base.a[5][5]=1;
base.a[6][5]=1;
base.a[6][6]=1;
}
void init1(ll a,ll b)
{
memset(hh.a,0,sizeof(hh.a));
hh.a[0][0]=b%MOD;
hh.a[0][1]=a%MOD;
hh.a[0][2]=3*3*3*3;
hh.a[0][3]=3*3*3;
hh.a[0][4]=3*3;
hh.a[0][5]=3;
hh.a[0][6]=1;
}
int main()
{
init();
int T,cas=1;
scanf("%d",&T);
while(T--)
{
ll n,a,b;
scanf("%lld%lld%lld",&n,&a,&b);
init1(a,b);
Matrix ans=(base^(n-2));
hh=hh*ans;
printf("%lld\n",hh.a[0][0]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: