您的位置:首页 > 其它

poj 3071 概率DP 位运算

2016-08-30 17:14 344 查看
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu

Submit Status Practice POJ 3071

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the
double
data type instead of
float
.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1


Sample Output

2


Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
= p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.
The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <stdlib.h>
#define MAXSIZE 500//(1<<7=2^7=128)
using namespace std;

int n;
double dp[MAXSIZE][MAXSIZE],p[MAXSIZE][MAXSIZE];

int get(int i,int j)//i,j队伍在第k轮(其实是k+1)轮交锋
{
for(int k = n-1;k>=0;k--)
if((i&(1<<k))^(j&(1<<k)))//注意括号!!!
return k;
}
//dp[i][k] 表示第k轮,i赢的概率
int main()
{
freopen("caicai.txt","r",stdin);
while(~scanf("%d",&n))
{
if(n==-1)
break;
memset(p,0,sizeof(p));
memset(dp,0,sizeof(dp));
int i,j,k;
for(i = 0;i<(1<<n);i++)
for(j = 0;j<(1<<n);j++)
scanf("%lf",&p[i][j]);
for(i = 0;i<(1<<n);i++)
dp[i][0] = 1.0;
for(k = 0;k<n;k++)//k从0开始,dp数组从1开始,0是自己跟自己对抗
for(i = 0;i<(1<<n);i++)
for(j = i+1;j<(1<<n);j++)
{
int t = get(i,j);
if(t==k)
{
dp[i][k+1] += dp[i][k]*dp[j][k]*p[i][j];//累加
dp[j][k+1] += dp[i][k]*dp[j][k]*p[j][i];
}
}
double mx = 0;
int ans = 0;
for(i = 0;i<(1<<n);i++)
{
if(dp[i]
>mx)
{
mx = dp[i]
;
ans = i;
}
}
cout<<ans+1<<endl;
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: