您的位置:首页 > 其它

Codeforces Problem 711A Bus to Udayland(brute force+implementation)

2016-08-30 09:08 337 查看
此文章可以使用目录功能哟↑(点击上方[+])

比赛链接→Codeforces Round #369 (Div. 2)




 Codeforces Problem 711A Bus to Udayland

Accept: 0    Submit: 0

Time Limit: 2 seconds    Memory Limit : 256 megabytes




 Problem Description

ZS the Coder and Chris the Baboon are travelling to Udayland! To get there, they have to get on the special IOI bus. The IOI bus has n rows of seats. There are 4 seats in each row, and the seats are separated into pairs by a walkway.
When ZS and Chris came, some places in the bus was already occupied.

ZS and Chris are good friends. They insist to get
a pair of neighbouring empty seats
. Two seats are considered neighbouring if they are in the same row and in the same pair. Given the configuration of the bus, can you help ZS and Chris determine where they should sit?



 Input

The first line of the input contains a single integer n (1 ≤ n ≤ 1000) — the number of rows of seats in the bus.

Then, n lines follow. Each line contains exactly 5 characters, the first two of them denote the first pair of seats in the row, the third character denotes the walkway (it always equals '|') and the last two of them denote the second pair of seats in the
row.

Each character, except the walkway, equals to 'O' or to 'X'. 'O' denotes an empty seat, 'X' denotes an occupied seat. See the sample cases for more details.



 Output

If it is possible for Chris and ZS to sit at neighbouring empty seats, print "YES" (without quotes) in the first line. In the next n lines print the bus configuration, where the characters in the pair of seats for Chris and ZS is changed with characters
'+'. Thus the configuration should differ from the input one by exactly two charaters (they should be equal to 'O' in the input and to '+' in the output).

If there is no pair of seats for Chris and ZS, print "NO" (without quotes) in a single line.

If there are multiple solutions, you may print any of them.



 Sample Input

6

OO|OX

XO|XX

OX|OO

XX|OX

OO|OO

OO|XX

4

XO|OX

XO|XX

OX|OX

XX|OX

5

XX|XX

XX|XX

XO|OX

XO|OO

OX|XO



 Sample Output

YES

++|OX

XO|XX

OX|OO

XX|OX

OO|OO

OO|XX

NO

YES

XX|XX

XX|XX

XO|OX

XO|++

OX|XO



 Hint

Note that the following is an incorrect configuration for the first sample case because the seats must be in the same pair.

O+|+X

XO|XX

OX|OO

XX|OX

OO|OO

OO|XX



 Problem Idea

解题思路:

【题意】
公共汽车上有n排座位,每排有4个座位,并被走道分为两对

当ZS和Chris上车时,有些位置已经有人坐了('X'),而有些位置则空着('O')

问ZS和Chris能否坐在相邻位置上,即两个位置位于同一排,且位于走道同一侧

若能,则把相应位置标记为'+',并输出;否则,输出"NO"

【类型】
brute force,implementation

【分析】

因为座位最多有1000排,每排只有4个,所以数据还是比较小的

完全可以暴力判断每一对座位

看该对中的两个座位是否都空着

只要存在这么一对座位,那此题就是有解的

否则,如果遍历完所有座位都没有找到符合的一对座位,那就不存在这样的解

【时间复杂度&&优化】

O(n)

题目链接→Codeforces Problem 711A Bus to Udayland



 Source Code

/*Sherlock and Watson and Adler*/
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include<stack>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<bitset>
#include<cmath>
#include<complex>
#include<string>
#include<algorithm>
#include<iostream>
#define eps 1e-9
#define LL long long
#define PI acos(-1.0)
#define bitnum(a) __builtin_popcount(a)
using namespace std;
const int N = 1005;
const int M = 100005;
const int inf = 1000000007;
const int mod = 1000000007;
char s
[10];
int main()
{
int n,i;
bool flag=false;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%s",s[i]);
if(!flag)
{
if(s[i][0]=='O'&&s[i][1]=='O')
s[i][0]=s[i][1]='+',flag=true;
else if(s[i][3]=='O'&&s[i][4]=='O')
s[i][3]=s[i][4]='+',flag=true;
}
}
if(flag)
{
puts("YES");
for(i=0;i<n;i++)
puts(s[i]);
}
else
puts("NO");
return 0;
}
菜鸟成长记
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: