您的位置:首页 > 其它

POJ 3292 Semi-prime H-numbers(类素数筛法)

2016-08-23 16:15 316 查看
Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers
are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit,
and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different.
In the example above, all five numbers areH-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input
21
85
789
0

Sample Output
21 0
85 5
789 62


H-numbers是一类4n+1的数(在这个问题里,只有这类数字)

H-primes是一类因子只有1和它本身的H-numbers(类似于平常我们见到的质数)

H-semi-primes是一类数是两个H-primes的乘积

打个表,然后输出就可以

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;
int H_number[1000011];
void fun()
{
int i,j;
memset(H_number,0,sizeof(H_number));
for(i=5;i<=1000001;i+=4)
{
for(j=5;j<=1000001;j+=4)
{
int t = i*j;
if(t > 1000001)
break;
if(H_number[i] == 0 && H_number[j] == 0)
H_number[t] = 1;
else
H_number[t] = -1;
}
}
int cnt = 0;
for(i=1;i<=1000001;i++)
{
if(H_number[i] == 1)
{
cout << i << endl;
cnt++;
}

H_number[i] = cnt;
}
}
int main(void)
{
int n;
fun();
while(scanf("%d",&n)&&n)
{
printf("%d %d\n",n,H_number
);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: