您的位置:首页 > 其它

POJ 3292 Semi-prime H-numbers

2014-07-21 11:15 393 查看
Semi-prime H-numbers

Time Limit: 1000MS
Memory Limit: 65536K


Total Submissions: 7372
Accepted: 3158

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime,
because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 

85

789

0

Sample Output

21 0

85 5

789 62

题意:不得不说题意很难懂!!就是找出1到输入的,只能拆成两个4n+1相乘的数的个数!!

不过这个题还是很有意义的,它让我深刻的认识到了打表的强大,这是继N皇后之后遇到的又一个打表神题!!

AC代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define M 1000001
using namespace std;

int aa[M+1];
int bb[M+1];

int main()
{
int i,j;
int n;
int t=0,tj=0;
memset(aa,0,sizeof aa);
for(i=5;i<=M;i+=4)
for(j=5;j<=M;j+=4)
{
if(i*j>M)
break;
if(aa[i]==0&&aa[j]==0)
aa[i*j]=1;
else aa[i*j]=-1;
}
int ans=0;
for(i=1;i<=M;i++)
{
if(aa[i]==1)
{
ans++;
}
bb[i]=ans;
}
while(~scanf("%d",&n)&&n)
{
printf("%d %d\n",n,bb
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj acm