您的位置:首页 > 其它

【HDU】1058 - Humble Numbers(dp)

2016-08-22 10:04 363 查看
点击打开题目


Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 23949    Accepted Submission(s): 10478


Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence

 

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

 

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

 

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

 

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

 

Source

University of Ulm Local Contest 1996

 

后面的是由前面的推出来的。

代码如下:

#include <stdio.h>
#include <cstring>
#include <algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
#define INF 0x3f3f3f3f
#define LL long long
int Min(int a,int b,int c,int d)
{
return min(min(min(a,b),c),d);
}
int main()
{
int num[42000] = {0,1};
int n2,n3,n5,n7;
int t;
n2 = n3 = n5 = n7 = 1;
for (int i = 2 ; i <= 5842 ; i++)
{
t = Min(num[n2]*2 , num[n3]*3 , num[n5]*5 , num[n7]*7);
num[i] = t;
if (t == num[n2]*2)
n2++;
if (t == num[n3]*3)
n3++;
if (t == num[n5]*5)
n5++;
if (t == num[n7]*7)
n7++;
}
int n;
while (~scanf ("%d",&n) && n)
{
if (n % 100 == 11 || n % 100 == 12 || n % 100 == 13)
printf ("The %dth humble number is %d.\n",n,num
);
else if (n % 10 == 1)
printf ("The %dst humble number is %d.\n",n,num
);
else if (n % 10 == 2)
printf ("The %dnd humble number is %d.\n",n,num
);
else if (n % 10 == 3)
printf ("The %drd humble number is %d.\n",n,num
);
else
printf ("The %dth humble number is %d.\n",n,num
);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: