您的位置:首页 > 其它

【HDU3374】 String Problem (最小最大表示法+KMP)

2016-08-17 15:56 369 查看

String Problem


Description

Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings:
String Rank
SKYLONG 1
KYLONGS 2
YLONGSK 3
LONGSKY 4
ONGSKYL 5
NGSKYLO 6
GSKYLON 7
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once.
Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

Input

Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.

Output

Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

Sample Input

abcder
aaaaaa
ababab


Sample Output

1 1 6 1
1 6 1 6
1 3 2 3








  用最大最小表示法,KMP求个数。
  注意特殊的时候在KMP中加入长度特判。

  最小最大表示法是求出循环子串得到最小最大表示。

  表示我之前并没有遇到过,貌似还有些神奇的应用?不知道、、

  但是打起来还是挺简单的,也很容易证明。

  

int get_st(bool p)
{
int i=1,j=2,k=0;
while(i<=l&&j<=l&&k<=l)
{
if(s[i+k]==s[j+k]) k++;
else if((s[i+k]>s[j+k])==(!p))
{
i+=k+1;
k=0;
}
else
{
j+=k+1;
k=0;
}
if(i==j) j++;
}
return mymin(i,j);
}


  

  这个我把最小表示和最大表示合在一起了。p=0是最小,p=1时最大。

  证明的话...连续匹配过程中一旦发现字符有小于其他字符的,那么他一定不是最大表示,且他前面连续的一段也不是。

本题代码如下:

 #include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
#define Maxn 1000010

char s[2*Maxn];
int nt[Maxn*2],l;

int mymin(int x,int y) {return x<y?x:y;}

int get_st(bool p) { int i=1,j=2,k=0; while(i<=l&&j<=l&&k<=l) { if(s[i+k]==s[j+k]) k++; else if((s[i+k]>s[j+k])==(!p)) { i+=k+1; k=0; } else { j+=k+1; k=0; } if(i==j) j++; } return mymin(i,j); }
void get_nt(int x)
{
nt[x]=x-1;int p=x-1;
for(int i=x+1;i<=x+l-1;i++)
{
while(s[i]!=s[p+1]&&p>=x) p=nt[p];
if(s[i]==s[p+1]) p++;
nt[i]=p;
}
}

int ffind(int x)
{
int ans=0;int p=x-1;
for(int i=1;i<=2*l;i++)
{
while((s[i]!=s[p+1]&&p>=x)||p-x+1>=l) p=nt[p];
if(s[i]==s[p+1]&&p-x+1<l) p++;
if(i>l&&p-x+1>=l) ans++;
}
return ans;
}

int main()
{
while(scanf("%s",s+1)!=EOF)
{
l=strlen(s+1);
for(int i=1;i<=l;i++) s[i+l]=s[i];
int st=get_st(0);
get_nt(st);
printf("%d %d ",st,ffind(st));

st=get_st(1);
get_nt(st);
printf("%d %d\n",st,ffind(st));
}
return 0;
}


HDU3374

2016-08-17 15:59:59
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: