您的位置:首页 > 其它

Rikka with Parenthesis II

2016-08-15 17:43 253 查看


Rikka with Parenthesis II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 2571    Accepted Submission(s): 913


Problem Description

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Correct parentheses sequences can be defined recursively as follows:

1.The empty string "" is a correct sequence.

2.If "X" and "Y" are correct sequences, then "XY" (the concatenation of X and Y) is a correct sequence.

3.If "X" is a correct sequence, then "(X)" is a correct sequence.

Each correct parentheses sequence can be derived using the above rules.

Examples of correct parentheses sequences include "", "()", "()()()", "(()())", and "(((())))".

Now Yuta has a parentheses sequence S,
and he wants Rikka to choose two different position i,j and
swap Si,Sj. 

Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.

It is too difficult for Rikka. Can you help her?

 

Input

The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100

For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.

 

Output

For each testcase, print "Yes" or "No" in a line.

 

Sample Input

3
4
())(
4
()()
6
)))(((

 

Sample Output

Yes
Yes
No
#include<stdio.h>
#include<string.h>
#include<stack>
#include<algorithm>
using namespace std;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
stack<char>s;
int n;
scanf("%d",&n);
char str[100005];
scanf("%s",str);
char x,y;

if(n%2==1)
printf("No\n");
else if(n==2)
{
x=str[0];
y=str[1];
if( x==')' && y=='(' ) printf("Yes\n");
else printf("No\n");
}
else
{
char ch;
while(!s.empty()) s.pop();
int i=0;
while(i<n)
{
ch=str[i++];
if(s.empty())
s.push(ch);
else if(ch==')'&&s.top()=='(')
s.pop();
else
s.push(ch);
}

if(s.empty()) printf("Yes\n");
else
{
if(s.size()==2)
{
x=s.top();
s.pop();
y=s.top();
if( x=='(' && y==')' ) printf("Yes\n");
else printf("No\n");
}
else if(s.size()==4)
{
int a=s.top();s.pop();
int b=s.top();s.pop();
int c=s.top();s.pop();
int d=s.top();s.pop();

if(d==')'&&c==')'&&b=='('&&a=='(')
printf("Yes\n");
else printf("No\n");
}

else printf("No\n");
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: