您的位置:首页 > 其它

hdu-5831 Rikka with Parenthesis II(贪心)

2016-08-11 18:58 274 查看
题目链接:

Rikka with Parenthesis II

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 65536/65536 K (Java/Others)

[align=left]Problem Description[/align]
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Correct parentheses sequences can be defined recursively as follows:
1.The empty string "" is a correct sequence.
2.If "X" and "Y" are correct sequences, then "XY" (the concatenation of X and Y) is a correct sequence.
3.If "X" is a correct sequence, then "(X)" is a correct sequence.
Each correct parentheses sequence can be derived using the above rules.
Examples of correct parentheses sequences include "", "()", "()()()", "(()())", and "(((())))".

Now Yuta has a parentheses sequence S, and he wants Rikka to choose two different position i,j and swap Si,Sj.

Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.

It is too difficult for Rikka. Can you help her?

[align=left]Input[/align]
The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100

For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.

[align=left]Output[/align]
For each testcase, print "Yes" or "No" in a line.

[align=left]Sample Input[/align]

3
4
())(

4
()()

6
)))(((

[align=left]Sample Output[/align]

Yes

Yes
No

题意:

问交换两个位置能否使这些括号匹配;

思路:

看不能匹配的括号数,多于两对就NO了;有个wa点就是()直接wa哭我了;

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <bits/stdc++.h>
#include <stack>
#include <map>

using namespace std;

#define For(i,j,n) for(int i=j;i<=n;i++)
#define mst(ss,b) memset(ss,b,sizeof(ss));

typedef  long long LL;

template<class T> void read(T&num) {
char CH; bool F=false;
for(CH=getchar();CH<'0'||CH>'9';F= CH=='-',CH=getchar());
for(num=0;CH>='0'&&CH<='9';num=num*10+CH-'0',CH=getchar());
F && (num=-num);
}
int stk[70], tp;
template<class T> inline void print(T p) {
if(!p) { puts("0"); return; }
while(p) stk[++ tp] = p%10, p/=10;
while(tp) putchar(stk[tp--] + '0');
putchar('\n');
}

const LL mod=1e9+7;
const double PI=acos(-1.0);
const LL inf=1e18;
const int N=1e5+10;
const int maxn=5e3+4;
const double eps=1e-12;

int n;
char s
;

int check()
{
int num1=0,num2=0;
For(i,1,n)
{
if(s[i]=='(')num1++;
else num2++;
}
if(num1!=num2)return 0;
if(n==2)
{
if(s[1]=='('&&s[2]==')')return 0;
return 1;
}
num1=0;num2=0;
For(i,1,n)
{
if(s[i]=='(')num1++;
else
{
if(num1==0)num2++;
else num1--;
}
}
if(num2>2)return 0;
return 1;
}
int main()
{
int T;
read(T);
while(T--)
{
read(n);
scanf("%s",s+1);
if(check())printf("Yes\n");
else printf("No\n");
}
return 0;
}


  

AC代码:
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: