您的位置:首页 > 理论基础 > 计算机网络

2016中国大学生程序设计竞赛--网络选拔赛 1001 A Water Problem

2016-08-15 13:35 369 查看

2016中国大学生程序设计竞赛–网络选拔赛

1001 A Water Problem

Description:

Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.

Input

There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0≤N), the length of N is up to 10000000.

Output

For the i-th test case, output Case #i: , then output “YES” or “NO” for the answer.

Sample Input
10001
0
333

Sample Output
Case #1: YES
Case #2: YES
Case #3: NO


题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5832

解题思路:判断输入的数能否被10001整除,因为10001是73和137的最小公倍数。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

#define N 12000000
#define INF 0x3f3f3f3f

char s
;

int main()
{
int k=0, len, x, ans;

while(~scanf("%s", s))
{
k++;
len = strlen(s);

x = 10001;
ans = 0;

for(int i = 0; i < len; i++)
ans = (ans * 10 + (s[i] - '0') % x) % x;

if(ans == 0)
printf("Case #%d: YES\n", k);
else
printf("Case #%d: NO\n", k);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  CCPC HDU 水题