您的位置:首页 > 理论基础 > 计算机网络

HDU 5832 A water problem(简单思维题目)【2016中国大学生程序设计竞赛 - 网络选拔赛】

2016-10-04 20:32 459 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5832

A water problem

Time Limit: 5000/2500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1197 Accepted Submission(s): 560

Problem Description

Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.

Input

There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0≤N), the length of N is up to 10000000.

Output

For the i-th test case, output Case #i: , then output “YES” or “NO” for the answer.

Sample Input

10001

0

333

Sample Output

Case #1: YES

Case #2: YES

Case #3: NO

Author

UESTC

Source

2016中国大学生程序设计竞赛 - 网络选拔赛

【题目意思】给你一个数,问你它是不是137和73的倍数。

【题目分析】137和73的最小公倍数是10001,然后问题就转化为问这个数是不是10001的倍数,接下来就简单了。

下面是AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

char a[10000005];
int main()
{
int kase=0;
while(~scanf("%s",a))
{
int sum=0;
for(int i=0;a[i]!='\0';i++)
{
sum=(sum*10+a[i]-'0')%10001;
}
if(sum==0)
{
printf("Case #%d: YES\n",++kase);
}
else
{
printf("Case #%d: NO\n",++kase);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐