您的位置:首页 > 理论基础 > 计算机网络

2016中国大学生程序设计竞赛 - 网络选拔赛 1001 A water problem hdu5832

2016-08-14 22:52 344 查看
Problem Description

Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days
in Xixi a year and 137 days
in Haha a year. 

Now you know the days N after
Big Bang, you need to answer whether it is the first day in a year about the two planets.

 

Input

There are several test cases(about 5 huge
test cases).

For each test, we have a line with an only integer N(0≤N),
the length of N is
up to 10000000.

 

Output

For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.

 

Sample Input

10001
0
333

 

Sample Output

Case #1: YES
Case #2: YES
Case #3: NO

 

Author

UESTC

 

Source

2016中国大学生程序设计竞赛
- 网络选拔赛

大整数会想到java,然而java会MLE

所以我们考虑按位读入取模,假设前面余数x,当前数位为y,那么当前位读入后余数为(x*10+y)%mod

#include<map>
#include<cmath>
#include<queue>
#include<vector>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
char x[10000001];
int main()
{
int k=0;
while(scanf("%s",x)!=EOF)
{
k++;
int lx=strlen(x);
int mod1=0,mod2=0;
int i;
for(i=0;i<lx;i++)
{
mod1=mod1*10+x[i]-'0';
mod2=mod2*10+x[i]-'0';
mod1%=73;
mod2%=137;
}
if(mod1==0&&mod2==0)
printf("Case #%d: YES\n",k);
else
printf("Case #%d: NO\n",k);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐