您的位置:首页 > 理论基础 > 计算机网络

HDU5832——A water problem(CCPC网络赛第一题)

2016-08-15 09:08 363 查看

A water problem

[align=center]Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 342    Accepted Submission(s): 187

[/align]

[align=left]Problem Description[/align]
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73
days in Xixi a year and 137
days in Haha a year.

Now you know the days N
after Big Bang, you need to answer whether it is the first day in a year about the two planets.
 

[align=left]Input[/align]
There are several test cases(about
5
huge test cases).

For each test, we have a line with an only integer
N(0≤N),
the length of N
is up to 10000000.
 

[align=left]Output[/align]
For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.
 

[align=left]Sample Input[/align]

10001
0
333

 

[align=left]Sample Output[/align]

Case #1: YES
Case #2: YES
Case #3: NO

 
解:大数取模运算,如果同时整除73和137,也就是整除10001。

#include<stdio.h>
#include<string.h>
char a[10000007];
int main()
{
int count=1;
while(gets(a)){
long long len=0;
len = strlen(a);
int sum=0;
for(long long i=0;i<len;i++){
sum=(sum*10+a[i]-'0')%10001;
}
if(sum) printf("Case #%d: NO\n",count++);
else printf("Case #%d: YES\n",count++);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息