您的位置:首页 > 理论基础 > 计算机网络

HDU5842——Lweb and String(CCPC网络赛第11题)

2016-08-15 10:25 363 查看

Lweb and String

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 266    Accepted Submission(s): 176

[/align]

[align=left]Problem Description[/align]
Lweb has a string S.

Oneday, he decided to transform this string to a new sequence.

You need help him determine this transformation to get a sequence which has the longest LIS(Strictly Increasing).

You need transform every letter in this string to a new number.

A
is the set of letters of S,
B
is the set of natural numbers.

Every injection f:A→B
can be treat as an legal transformation.

For example, a String “aabc”, A={a,b,c},
and you can transform it to “1 1 2 3”, and the LIS of the new sequence is 3.

Now help Lweb, find the longest LIS which you can obtain from
S.

LIS: Longest Increasing Subsequence. (https://en.wikipedia.org/wiki/Longest_increasing_subsequence)
 

[align=left]Input[/align]
The first line of the input contains the only integer
T,(1≤T≤20).

Then T
lines follow, the i-th line contains a string S
only containing the lowercase letters, the length of
S
will not exceed 105.
 

[align=left]Output[/align]
For each test case, output a single line "Case #x: y", where x is the case number, starting from 1. And y is the answer.
 

[align=left]Sample Input[/align]

2
aabcc
acdeaa

 

[align=left]Sample Output[/align]

Case #1: 3
Case #2: 4

 

解:开始看到LIS以为是递增最大子序列,用dp和二分写完之后,WA,后来才发现,直接统计不同字母数量就可以了。给出LIS对于此题的代码,以及只统计不同字母数量的代码。

dp+二分,n*log(n):
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
char str[100010];
int number[100010];
int dp[100010];
int insert(int num,int end)
{
int begin=0;
while(begin<end-1){
int mid=(begin+end)/2;
if(dp[mid]>=num)
end=mid;
else
begin=mid;
}
dp[begin+1]=num;
return begin+1;
}
int main()
{
int T;
int i,j;
int count=0;
scanf("%d%*c",&T);
while(T--)
{
memset(number,0,sizeof(number));
count++;
gets(str);
int leng = strlen(str);
for(int i=0;i<100010;i++){
dp[i]=99999;
}
for(int i=0;i<leng;i++)
number[i]=str[i]-'a'+1;
sort(number,number+leng);
for(int i=0;i<leng;i++){
insert(number[i],leng-1);
}
printf("Case #%d: %d\n",count,insert(99999,leng)-1);
for(int i=0;i<100010;i++){
dp[i]=99999;
}
}
return 0;
}


直接统计不同字母数量,n:
#include<stdio.h>
#include<string.h>

int a[27];
char b[100010];

int main()
{
int t;
int count=1;
scanf("%d",&t);
getchar();
while(t--){
memset(a,0,sizeof(a));
int x=0;
gets(b);
int len=strlen(b);
for(int i=0;i<len;i++){
a[b[i]-'a']=1;
}
for(int i=0;i<26;i++){
if(a[i]){
x++;
}
}
printf("Case #%d: %d\n",count++,x);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息