您的位置:首页 > 其它

hdu 5832 A water problem(简单数论)

2016-08-14 23:17 330 查看


A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 291    Accepted Submission(s): 161


Problem Description

Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days
in Xixi a year and 137 days
in Haha a year. 

Now you know the days N after
Big Bang, you need to answer whether it is the first day in a year about the two planets.

 

Input

There are several test cases(about 5 huge
test cases).

For each test, we have a line with an only integer N(0≤N),
the length of N is
up to 10000000.

 

Output

For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.

 

Sample Input

10001
0
333

 

Sample Output

Case #1: YES
Case #2: YES
Case #3: NO

 

Author

UESTC

 

Source

2016中国大学生程序设计竞赛
- 网络选拔赛
题意:有两个周期,求n%两个数是不是相等,相等输出YES,否则NO

思路:虽然本人是蒟蒻,不过此题抢到了一血还是挺开心的= = 

后面惨不忍睹了。最后A了四个题学校水平不行也晋级不了,可惜。

只要对每一位都取模即可,具体可以看代码。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 10000050
char a
;
int main()
{
int n=1;
while(~scanf("%s",&a))
{
int len=strlen(a);
int now=0,now1=0;
for(int i=0;i<len;i++)
{
now=(now*10+a[i]-'0')%73;
now1=(now1*10+a[i]-'0')%137;
}
if(now==now1) printf("Case #%d: YES\n",n++);
else printf("Case #%d: NO\n",n++);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: