您的位置:首页 > 其它

sg函数_____A Chess Game( hdu 2425 )

2016-08-08 16:54 302 查看
Description

Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no
cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more.
If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again. 

Do you want to challenge me? Just write your program to show your qualification!
Input

Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position
i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions
of chesses. A line with number 0 ends the test case.
Output

There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.
Sample Input
4
2 1 2
0
1 3
0
1 0
2 0 2
0

4
1 1
1 2
0
0
2 0 1
2 1 1
3 0 1 3
0

Sample Output
WIN
WIN
WIN
LOSE
WIN


题目意思:
首先给出N个点,接下来的N line 的 i-th line 表示与 i-th 点的后继点。构成了n个点的有向无环图。

然后多次询问,每次询问给出M个点,表示开始的时候这M个点都有一个棋子。当M为0的时候退出询问。

游戏内容为。两个人轮流移动棋子,每次只能移动一个棋子,只能将棋子从该点沿着有向边移动到后继点。当某人无法移动棋子的时候输。

问先手赢还是后手赢?

分析:

显然的SG函数,通过递归求得每个点的SG值,然后将每个棋子所在点的SG值异或起来就是整个游戏的SG值。

注意:递归求sg的时候vis一定只能作为局部变量!!!!

代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn = 1024;
int sg[maxn];
vector<int> edge[1024];
int n;

int getsg(int tar)
{
if(sg[tar]!= -1) return sg[tar];
if(edge[tar].size() == 0)return sg[tar] = 0;
bool vis[maxn] = {false};
for(int i = 0 ; i < edge[tar].size() ; i ++)
vis[getsg(edge[tar][i])] = true;
for(int i = 0 ; i < maxn ; i ++)
if(!vis[i]) return sg[tar] = i;
}

int main()
{
int m;
while(scanf("%d",&n)!=EOF)
{
for(int i = 0 ; i < n ; i ++)
{
int cnt,u,v;
scanf("%d",&cnt);
edge[i].clear();
for(int j = 0 ; j < cnt ; j ++)
{
scanf("%d",&u);
edge[i].push_back(u);
}
sg[i] = -1;
}
while(scanf("%d",&m),m)
{
int ans = 0,step;
for(int i = 0 ; i < m ; i ++)
{
scanf("%d",&step);
ans ^= getsg(step);
}
if(ans == 0) printf("LOSE\n");
else printf("WIN\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: