您的位置:首页 > 产品设计 > UI/UE

hdu 5783 Divide the Sequence

2016-08-02 17:05 375 查看
Problem Description

Alice has a sequence A, She wants to split A into as much as possible continuous subsequences, satisfying that for each subsequence, every its prefix sum is not small than 0.

 

Input

The input consists of multiple test cases. 

Each test case begin with an integer n in a single line.

The next line contains n integers A1,A2⋯An.
1≤n≤1e6
−10000≤A[i]≤10000

You can assume that there is at least one solution.

 

Output

For each test case, output an integer indicates the maximum number of sequence division.

 

Sample Input

6
1 2 3 4 5 6
4
1 2 -3 0
5
0 0 0 0 0

 

Sample Output

6
2
5

因为s写的int
而应该用long long 错了很长时间
逆序贪心,
把长度为n的序列分成尽量多的连续段,使得每一段的每个前缀和都不小于0。保证有解。 从后往前贪心分段即可。
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>

using namespace std;

int a[1001000];
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
int t=n;
for(int i=n-1;i>=0;i--)
{
if(a[i]<0)
{
long long s=a[i];
while(s<0){
t--;
s+=a[--i];
}
}
}
printf("%d\n",t);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: