您的位置:首页 > 其它

POJ 3461 Oulipo【KMP】【模板题】(找出第一个字符串在第二个字符串中出现次数)

2017-08-20 21:25 549 查看
Oulipo

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 42886 Accepted: 17234
Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program
that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T,
count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output
1
3
0

Source

BAPC 2006 Qualification

找出第一个字符串在第二个字符串中出现次数

#include <iostream>
#include <cmath>
#include <algorithm>
#include <cstdio>
#include <stdlib.h>
#include <string>
#include <cstring>
#include <map>
#include <set>
#include <queue>
#include <stack>
#define INF 0x3f3f3f3f
#define ms(x,y) memset(x,y,sizeof(x))
using namespace std;

typedef long long ll;

const double pi = acos(-1.0);
const int mod = 1e9 + 7;
const int maxn = 1e5 + 10;

int nextval[100010];
char s[1000100],p[1000010];

//p为模式串
void getnext(char p[], int nextval[])      //朴素kmp,nextval[i]即为1~i-1的最长前后缀长度
{
int len=strlen(p);
int i=0,j=-1;
nextval[0]=-1;
while(i<len)
{
if(j==-1||p[i]==p[j])
{
nextval[++i]=++j;
}
else
j=nextval[j];
}
}

//在s中找p出现的次数
int KMP(char s[], char p[], int nextval[])
{
getnext(p,nextval);
int ans=0;
int i=0;    //s下标
int j=0;    //p下标
int s_len=strlen(s);
int p_len=strlen(p);
while(i<s_len&&j<p_len)
{
if(j==-1||s[i]==p[j])
{
i++;
j++;
}
else
j=nextval[j];

if(j==p_len)
{
j=nextval[j];   //注意这个优化比较重要
ans++;
}
}
return ans;
}

int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
int n;
scanf("%d",&n);
while(n--)
{
ms(p,0);
ms(s,0);
scanf(" %s %s",p,s);
printf("%d\n",KMP(s,p,nextval));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: