您的位置:首页 > 其它

【HDU】-1325-Is It A Tree?(并查集)

2016-08-01 21:59 369 查看


Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 21760    Accepted Submission(s): 4911


Problem Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.







In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not. 

 

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers;
the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero. 

 

Output

For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1). 

 

Sample Input

6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1

 

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

 
莫名其妙啊!!!一直wa,再一看都不知道自己啥时候A了,呜呜~~~~(>_<)~~~~ 

题意:判断是不是数(知道是树的条件就好。1,没有环。2,除了根节点其他节点入度为 1 。3,根节点唯一。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
#define CLR(a,b)  memset(a,b,sizeof(a))
int f[100010];
int num[100010];
int vis[100010];
int find(int x)
{
if(x!=f[x])
f[x]=find(f[x]);
return f[x];
}
bool join(int x,int y)
{
int dx=find(x);
int dy=find(y);
if(dx!=dy)
{
f[dy]=dx;
return true;
}
return false;
}
int main()
{
int ant=0;
int a,b;
while(~scanf("%d %d",&a,&b))
{
ant++;
bool flag=true;
CLR(vis,0);
CLR(num,0);
vis[a]=1;
vis[b]=1;
num[b]++;
if(a<0&&b<0)			//小于 0 退出
break;
else if(a==0&&b==0)
printf("Case %d is a tree.\n",ant);
else
{
for(int i=0;i<100010;i++)
f[i]=i;
join(a,b);
while(~scanf("%d %d",&a,&b))
{
if(a==0&&b==0)
break;
vis[a]=1;
vis[b]=1;
num[b]++;
if(!join(a,b))         //有环,不是树
flag=false;
if(num[b]>1)			//入度大一 1 ,不是
flag=false;
}
if(!flag)
{
printf("Case %d is not a tree.\n",ant);
continue;
}
int num=0;
for(int i=0;i<100010;i++)
{
if(vis[i]&&find(i)==i)
num++;
}
if(num>1)                	//根节点不唯一,不是
printf("Case %d is not a tree.\n",ant);
else
printf("Case %d is a tree.\n",ant);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: