您的位置:首页 > 大数据 > 人工智能

2016 Multi-University Training Contest 4 Another Meaning

2016-07-29 15:26 363 查看

Another Meaning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 678    Accepted Submission(s): 314


[align=left]Problem Description[/align]As is known to all, in many cases, a word has two meanings. Such as “hehe”, which not only means “hehe”, but also means “excuse me”. 
Today, ?? is chating with MeiZi online, MeiZi sends a sentence A to ??. ?? is so smart that he knows the word B in the sentence has two meanings. He wants to know how many kinds of meanings MeiZi can express. 
[align=left]Input[/align]The first line of the input gives the number of test cases T; T test cases follow.
Each test case contains two strings A and B, A means the sentence MeiZi sends to ??, B means the word B which has two menaings. string only contains lowercase letters.

Limits
T <= 30
|A| <= 100000
|B| <= |A|

 
[align=left]Output[/align]For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the number of the different meaning of this sentence may be. Since this number may be quite large, you should output the answer modulo 1000000007. 
[align=left]Sample Input[/align]
4
hehehe
hehe
woquxizaolehehe
woquxizaole
hehehehe
hehe
owoadiuhzgneninougur
iehiehieh 
[align=left]Sample Output[/align]
Case #1: 3
Case #2: 2
Case #3: 5
Case #4: 1

HintIn the first case, “ hehehe” can have 3 meaings: “*he”, “he*”, “hehehe”.
In the third case, “hehehehe” can have 5 meaings: “*hehe”, “he*he”, “hehe*”, “**”, “hehehehe”.
 
[align=left]Author[/align]FZU 
[align=left]Source[/align]2016 Multi-University Training Contest 4

题意:有两个串A和B,其中B有两个意思,求A能组成多少种意思思路,先用kmp把A串中相同的子串末尾标记起来,在来进行dp;

 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=100005;
const int mod = 1e9+7;
int nexta
,vis
,dp
;
char a
,b
;
int n,m;
void getnext()
{
memset(nexta,0,sizeof nexta);
int j=-1,i=0;
nexta[0]=-1;
while(i<n)
{
if(j==-1||b[j]==b[i]) i++,j++,nexta[i]=j;
else
j=nexta[j];
}
}
void kmp()
{
int i=0,j=0;
while(i<n&&j<m)
{
if(j==-1||a[i]==b[j])
i++,j++;
else
j=nexta[j];
if(j==m)
{
j=nexta[j];
vis[i]=1;
}
}
}
int main()
{
int t,ca=1;
scanf("%d",&t);
while(t--)
{
memset(vis,0,sizeof vis);
cin>>a>>b;
n=strlen(a);
m=strlen(b);
getnext();
kmp();
dp[0]=1;
for(int i=1;i<=n;i++)
{
dp[i]=dp[i-1];
if(vis[i])
dp[i]+=dp[i-m];
dp[i]%=mod;
}
printf("Case #%d: %d\n",ca++,dp
);
}
return 0;

}




 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: