您的位置:首页 > 其它

The Frog's Games(二分)

2016-07-28 20:51 274 查看
D - The Frog's Games
Time Limit:1000MS     Memory Limit:65768KB     64bit IO Format:%I64d & %I64u
Submit

  Status

Description

The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000).
There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 

are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).

 

Input

The input contains several cases. The first line of each case contains three positive integer L, n, and m. 

Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.

 

Output

For each case, output a integer standing for the frog's ability at least they should have.

 

Sample Input

6 1 2

2

25 3 3

11 

2

18 

 

Sample Output

4
11

#include<cstdio>
#include<algorithm>
using namespace std;
int L,n,m,i;
int num[500010];
bool judge(int a)
{
int last=0;
int ast=0;
for(i=1;i<=n+1;)
{
if(num[i]<=last+a)
i++;
else{
if(last==num[i-1])
return false;
last=num[i-1];
ast++;
}
}
ast++;
return ast<=m;
}
int main()
{
int mid,ans;
while(scanf("%d %d %d",&L,&n,&m)!=EOF)
{
for(i=1;i<=n;i++)
{
scanf("%d",&num[i]);
}
sort(num,num+n+1);
num[n+1]=L;
int l=1,r=L;
while(r>=l)
{
mid=(l+r)/2;
if(judge(mid))
{
ans=mid;
r=mid-1;
}
else{
l=mid+1;
}
}
printf("%d\n",ans);
}
return 0;
}//D
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  二分