您的位置:首页 > 其它

【hdu 2795】Billboard 【线段树训练 3】

2016-07-28 17:42 309 查看
Billboard

Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 18769 Accepted Submission(s): 7877

Problem Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.

Sample Input

3 5 5

2

4

3

3

3

Sample Output

1

2

1

3

-1

Author

hhanger@zju

Source

HDOJ 2009 Summer Exercise(5)

Recommend

lcy

题意:有个公告板,大小为h*w,要贴n张公告,每个公告的长度是k,高度固定为1,公告放的要尽可能靠上并尽可能靠左,每给出一张公告,要求这个公告在满足要求的情况下放在了第几层。

思路:按照线段树的做法的话,因为公告的高度固定为1,可以对公告板的高度进行线段花费,将其现在的宽度值存起来,然后每次遍历从左子树开始往下走,直到走到叶子节点满足要求即可

#include<cstdio>
#include<iostream>
#include<cmath>
#include<algorithm>

using namespace std;

//Global Variables & Definations
int h,w,n,k,ans;
#define maxn 200001
struct Tree{
int l,r;
int v;
}e[maxn*4];

void build(int u,int l,int r)
{
e[u].l=l;
e[u].r=r;
e[u].v=w;
if(l==r)return;
int mid = (l+r)>>1;
build(u<<1,l,mid);
build(u<<1|1,mid+1,r);
}
void update(int u,int l,int r,int k)
{
if(l==r)
{
e[u].v-=k;
ans = l;
return;
}
int mid = (l+r)>>1;
if(k<=e[u<<1].v)update(u<<1,l,mid,k);
else update(u<<1|1,mid+1,r,k);
e[u].v=max(e[u<<1].v,e[u<<1|1].v);
}
//End Global Variables & Definations

//Main Stucture
int main()
{
//  ios::sync_with_stdio(false);
while(scanf("%d%d%d",&h,&w,&n)==3)//cin>>h>>w>>n
{
if(h>n)h=n;
build(1,1,h);
ans = -1;
for(int i=1;i<=n;i++)
{
//  cin>>k;
scanf("%d",&k);
if(k<=e[1].v)update(1,1,h,k);
printf("%d\n",ans);
//  cout<<ans<<endl;
ans = -1;
}
}
return 0;
}
//End Main Sturcture
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: