您的位置:首页 > 其它

HDOJ 1241 Oil Deposits【DFS】

2016-07-28 17:41 357 查看

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 24447    Accepted Submission(s): 14052

[align=left]Problem Description[/align]
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the
land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plt containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit.
Oil deposits can be quite large and may contain numerous pockoets. Your job is to determine how many different oil deposits are contained in a grid. 

[align=left]Input[/align]
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input;
otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

[align=left]Output[/align]
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain
more than 100 pockets.

[align=left]Sample Input[/align]

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 
[align=left]Sample Output[/align]

0
1
2
2寻找石油,石油相邻的8个方向若是有石油,则属于一个石油地方。
代码:
#include<stdio.h>
#include<string.h>
int n,m;
char map[110][110];
int dx[8]={1,-1,0,0,-1,-1,1,1};
int dy[8]={0,0,-1,1,-1,1,-1,1};
void dfs(int x,int y)
{
if(x<0||x>=m||y<0||y>=n)
return;
if(map[x][y]=='*')
return;
map[x][y]='*';
for(int i=0;i<8;i++)
{
dfs(x+dx[i],y+dy[i]);
}
}
int main()
{
while(scanf("%d%d",&m,&n)&&(n||m))
{
int sum=0;
for(int i=0;i<m;i++)
{
scanf("%s",map[i]);
}
for(int i=0;i<m;i++)
{
for(int j=0;j<n;j++)
{
if(map[i][j]=='@')
{
sum++;
dfs(i,j);
//printf("%d\n",sum);
}
}
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: