您的位置:首页 > 其它

杭电1050解题报告

2016-07-28 15:18 337 查看
[align=left] [/align]
[align=left]题目内容:[/align]
[align=left] [/align]
[align=left] [/align]
[align=left]Problem Description[/align]
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is
narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving
a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make
it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

 

[align=left]Input[/align]
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents
the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining
test cases are listed in the same manner as above.

 

[align=left]Output[/align]
The output should contain the minimum time in minutes to complete the moving, one per line.

 

[align=left]Sample Input[/align]

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50

 

[align=left]Sample Output[/align]

10
20
30   解题思路:本题为贪心算法,为求最优时间,可以先将走廊两侧房间均加1除以2使得两侧房间数组下标相等,定义一个数组,将数组赋初值为0,遍历数组,经过一次房间则加1,最后找到数组里最大的数即最优解。 解题代码:  #include<stdio.h>
int main (void)
{
    int n,i,t,k,a,b;
    scanf("%d",&n);
    while(n--)
    {
        int s[201]={0};//将数组赋初值为0
        scanf("%d",&k);
        while(k--)
        {
            scanf("%d%d",&a,&b);
            if(a>b)//若a比b大则交换
            {
                t=a;
                a=b;
                b=t;
            }
            for(i=(a+1)/2;i<=(b+1)/2;i++)
            {
                s[i]++;//遍历数组将经过的房间数加1
            }
        }
        for(i=1;i<201;i++)
        {
            if(s[0]<s[i]) s[0]=s[i];//找出数组内最大值即最优时间
        }
        printf("%d\n",s[0]*10);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: