您的位置:首页 > 其它

POJ-2049-Finding Nemo

2016-07-28 09:26 423 查看
Finding Nemo

Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 8852 Accepted: 2086
Description

Nemo is a naughty boy. One day he went into the deep sea all by himself. Unfortunately, he became lost and couldn't find his way home. Therefore, he sent a signal to his father, Marlin, to ask for help. 

After checking the map, Marlin found that the sea is like a labyrinth with walls and doors. All the walls are parallel to the X-axis or to the Y-axis. The thickness of the walls are assumed to be zero. 

All the doors are opened on the walls and have a length of 1. Marlin cannot go through a wall unless there is a door on the wall. Because going through a door is dangerous (there may be some virulent medusas near the doors), Marlin wants to go through as few
doors as he could to find Nemo. 

Figure-1 shows an example of the labyrinth and the path Marlin went through to find Nemo. 



We assume Marlin's initial position is at (0, 0). Given the position of Nemo and the configuration of walls and doors, please write a program to calculate the minimum number of doors Marlin has to go through in order to reach Nemo.
Input

The input consists of several test cases. Each test case is started by two non-negative integers M and N. M represents the number of walls in the labyrinth and N represents the number of doors. 

Then follow M lines, each containing four integers that describe a wall in the following format: 

x y d t 

(x, y) indicates the lower-left point of the wall, d is the direction of the wall -- 0 means it's parallel to the X-axis and 1 means that it's parallel to the Y-axis, and t gives the length of the wall. 

The coordinates of two ends of any wall will be in the range of [1,199]. 

Then there are N lines that give the description of the doors: 

x y d 

x, y, d have the same meaning as the walls. As the doors have fixed length of 1, t is omitted. 

The last line of each case contains two positive float numbers: 

f1 f2 

(f1, f2) gives the position of Nemo. And it will not lie within any wall or door. 

A test case of M = -1 and N = -1 indicates the end of input, and should not be processed.
Output

For each test case, in a separate line, please output the minimum number of doors Marlin has to go through in order to rescue his son. If he can't reach Nemo, output -1.
Sample Input
8 9
1 1 1 3
2 1 1 3
3 1 1 3
4 1 1 3
1 1 0 3
1 2 0 3
1 3 0 3
1 4 0 3
2 1 1
2 2 1
2 3 1
3 1 1
3 2 1
3 3 1
1 2 0
3 3 0
4 3 1
1.5 1.5
4 0
1 1 0 1
1 1 1 1
2 1 1 1
1 2 0 1
1.5 1.7
-1 -1

Sample Output
5
-1

将所有坐标都放大两倍来构建地图

如果用队列的话被压入的node.step大小无法控制,所以用优先 队列

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int n, m, x, y, d, t;
int xmax,xmin, ymax, ymin;
double f1, f2;
int Map[500][500];
bool vis[500][500];
struct node
{
int x,y,step;
bool operator < (const node &b) const
{
if(step==b.step)
{
if(x==b.x)
{
return b.y<y;
}
else
{
return b.x<x;
}
}
else
{
return b.step<step;
}
}
}p, q;
int tx[] = {1, 0, -1, 0};
int ty[]=  {0, -1, 0, 1};
void bfs(int x, int y)
{
memset(vis, 0,sizeof(vis));
priority_queue <struct node ,vector <struct node>,less<struct node> >qq;
p.step = 0;
p.x= x;
p.y= y;
qq.push(p);
while(!qq.empty())
{
p = qq.top();
vis[p.y][p.x] = 1;
qq.pop();
if(!(p.x>=xmin&&p.x<=xmax&&p.y<=ymax&&p.y>=ymin))
{
printf("%d\n",p.step);
return;
}
else
{
for(int i = 0; i<4;++i)
{
q.x = p.x+tx[i];
q.y =p.y+ty[i];
if(!vis[q.y][q.x]&&Map[q.y][q.x]!=1)
{
if(Map[q.y][q.x]==2)q.step = p.step+1;
else q.step = p.step;
qq.push(q);
}
}
}
}
printf("-1\n");
}
int main()
{
while(~scanf("%d%d", &m, &n))
{
xmax = ymax = 0;
xmin = ymin = 1000;
if(m==-1&&n==-1)break;
memset(Map, 0,sizeof(Map));
while(m--)
{
scanf("%d%d%d%d",&x,&y,&d,&t);
x = 2*x-1;
y = 2*y-1;
if(!d)
{
for(int i = x;i<=x+2*t;++i)
Map[y][i] = 1;
if(x+2*t>xmax)xmax = x+2*t;
if(y>ymax)ymax = y;
if(x<xmin)xmin = x;
if(y<ymin)ymin = y;
}
else
{
for(int i = y; i<=y+2*t;++i)
Map[i][x] = 1;
if(x>xmax)xmax = x;
if(y+2*t>ymax)ymax = y+2*t;
if(x<xmin)xmin = x;
if(y<ymin)ymin = y;
}
}
while(n--)
{
scanf("%d%d%d", &x, &y,&d);
x = 2*x-1;
y = 2*y-1;
if(!d)
{
Map[y][x+1] =2;
}
else
{
Map[y+1][x] = 2;
}
}
scanf("%lf%lf", &f1, &f2);
x = (int)(f1)*2;
y = (int)(f2)*2;
if (y>ymax||y<ymin||x<xmin||x>xmax||(n==0&&m==0))
{
printf("0\n");
continue;
}
bfs( x,  y);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: