您的位置:首页 > 大数据 > 人工智能

【 POJ 1363 】Rails

2016-07-26 01:58 323 查看
一道把我坑了的简单水题。

不知道为什么深究了,而且弄不清,一直到凌晨,现在北京时间1.14——留作纪念。



其实那个先对比还是挺巧妙地。

如果a和b[]不等的话,压栈,相等的话再看栈是不是为空,不空则弹栈,如果空的话直接进入下个比较。

不多说,下面都有注释。

————————————————————————————————————————

题目:Rails

Rails

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 31401 Accepted: 12201

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, …, N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, …, aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

Input

The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, …, N. The last line of the block contains just 0.

The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last “null” block of the input.

Sample Input

5

1 2 3 4 5

5 4 1 2 3

0

6

6 5 4 3 2 1

0

0

Sample Output

Yes

No

Yes

Source

Central Europe 1997

——————————————————————————————————————————

代码:

#include<stack>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

int main()
{
int a,b,i,flag;
int n;
int t[1010];
while( ~scanf("%d",&n) && n)
{
while( ~scanf("%d",&t[1]) )
{
flag=1;
if( t[1] == 0 )
{
printf("\n"); break;
}
for( i=2; i <= n; i++ )//注意边界,从一开始,故加等号
{
scanf("%d",&t[i]);
}
stack<int>s;
a = b = 1;
while( b <= n )     //所有给出的序列模拟结束 退出循环
{
if( a == t[b])   //等于的话相当于是一个入栈后直接出栈的过程,所以直接到下一个元素
{
a++;b++;
}
else if( !s.empty() && s.top() == t[b] )
{                   //如果 栈不空,栈顶元素等于t[b]那么弹栈,继续
s.pop();
b++;
}
else if( a <= n )  // 巧妙的关键,模拟入栈。
{
s.push(a);
a++;      //先存再加
}
else  //如果可以按照前面的循环走完,就证明模拟成功,结论正确。
{    // 否则flag = 0 证明给出的列不满足条件。
flag = 0;
break;
}
}
if( flag ) printf("Yes\n");
else printf("No\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj