您的位置:首页 > 其它

POJ-1753-Flip Game

2016-07-25 15:42 281 查看
Flip Game

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39964 Accepted: 17350
Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces,
thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
Choose any one of the 16 pieces. 

Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example: 

bwbw 

wwww 

bbwb 

bwwb 

Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 

bwww 

wwwb 

wwwb 

The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible"
(without quotes).
Sample Input
bwwb
bbwb
bwwb
bwww

Sample Output
4

Source

Northeastern Europe 2000
#include<stdio.h>
#include<queue>
#include<math.h>
#include<string.h>
using namespace std;
bool Map[6][6];
int step = -1, flag = 0;
int tx[] = {1,0,-1,0,0};
int ty[] = {0,1,0,-1,0};
void Filp(int x, int y) // 翻转
{
for(int i = 0; i<5; ++i)
{
int xx = x+tx[i];
int yy = y+ty[i];
Map[xx][yy] = !Map[xx][yy];
}
}
int Make_sure() //判断当前是否为目标状态
{
int k = 0;
for(int i = 1; i<=4; ++i)
for(int j = 1; j<=4; ++j)
k+=Map[i][j];
if(k==16||k==0)return 1;
else return 0;
}
void dfs(int x, int y, int s)
{
if(Make_sure())
{
flag = 1;
if(step>s||step == -1)step = s;
return;
}
if(y>4)
{
++x;
if(x>4)return;
y = 1;
}
dfs(x, y+1, s);
Filp(x, y);
dfs(x, y+1, s+1);
Filp(x, y);

}
int main()
{
char s[5];
for(int i = 1; i<=4; ++i)
{
scanf("%s", s);
for(int j = 1; j<=4; ++j)
{
if(s[j-1]=='b')Map[i][j] = 1;
else Map[i][j] = 0;
}
}
dfs(1, 1, 0);
if(flag)printf("%d\n", step);
else printf("Impossible\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: