您的位置:首页 > 其它

hdu5747 贪心

2016-07-25 11:28 441 查看
Aaronson

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 498 Accepted Submission(s): 299

Problem Description

Recently, Peter saw the equation x0+2x1+4x2+…+2mxm=n. He wants to find a solution (x0,x1,x2,…,xm) in such a manner that ∑i=0mxi is minimum and every xi (0≤i≤m) is non-negative.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤105), indicating the number of test cases. For each test case:

The first contains two integers n and m (0≤n,m≤109).

Output

For each test case, output the minimum value of ∑i=0mxi.

Sample Input

10

1 2

3 2

5 2

10 2

10 3

10 4

13 5

20 4

11 11

12 3

Sample Output

1

2

2

3

2

2

3

2

3

2

宝宝之间都没A过BestCoder里的题目,感觉自己还是太水了,拿个最简单的再试试,没想到一次就A了。可以的。

题目的意思很明显吧,就不说了,值的一提的是, Xi是非负的整数!

这里看n和m的范围就知道,其实n也就是int的范围内,所以Xi (i>30) 的取值肯定等于0。

可能有的朋友会纠结,那31和32哪去了?int 可是4个字节。

有点常识的都知道int 是补码表示,表示范围是2^31 -1 到 2^31 , 所以2^31-1 >n>0。所以只考虑Xi<=30的时候。

还有一个就是题目要求SumXi 值最小,不难想到用贪心就能很好得解决了。从后向前贪。

好的, 上代码,就几行:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int n,m;
int main(){
int t;
//freopen("hdu5747.in", "rw", stdin);
cin>>t;
while(t--){
scanf("%d%d", &n, &m);
int ans=0;
int ran=min(30, m);
for(int i=ran;i>=0;i--){
int tmp;
tmp=pow(2, i);
if(tmp>n)continue;
ans+=n/tmp;
n%=tmp;
}
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu5747 贪心