您的位置:首页 > 其它

HDU 1002 ????

2016-07-23 22:22 190 查看
HDU 1002 大数相加,题目的链接如下:

http://acm.hdu.edu.cn/showproblem.php?pid=1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 315379 Accepted Submission(s): 61186

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2

1 2

112233445566778899 998877665544332211

Sample Output

Case 1:

1 + 2 = 3

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110

#include <iostream>
#include <cstring>
#include <string>
using namespace std ;
/*int OJ(int m,int n)
{
int r;
r=m%n;
while(r!=0){
m=n;
n=r;
r=m%n;
}
return n;
}*/
string add(string a, string b)
{
if(a == "0" && b=="0") return "0";
if(a=="0") return b;
if(b=="0") return a;
string max , min;
max = a , min = b ;
if(a.length() < b.length()){
max = b ;
min = a ;
}
int c = max.length()-1, d = min.length()-1;
for(int i=d ; i>=0 ; i--){
max[c--] += min[i] - '0';
}
for(int i=max.length()-1 ; i>0 ; i--){
if(max[i] > '9'){
max[i] -= 10 ;
max[i-1]++;
}
}
if(max[0] > '9')
{
max[0] -= 10;
max = '1' + max ;
}
return max ;
}
string str1 , str2 , str3 ;
using namespace std ;
int main()
{
int n , t = 1;
cin >> n ;
for(int i=0 ; i<n ; i++)
{
cin >> str1 >> str2 ;
cout << "Case " << t << ":" << endl ;
str3 = add(str1, str2);
cout << str1 << " + " << str2 <<  " = " << str3 << endl;
if(t<n) cout << endl ;
t++;
}
return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  大数加法