您的位置:首页 > 运维架构

[hdu 4405] Aeroplane chess [概率DP & 期望]

2016-07-22 12:16 411 查看
[align=center]New~ 欢迎参加2016多校联合训练的同学们~
[/align]

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3221    Accepted Submission(s): 2048


[align=left]Problem Description[/align]
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are
1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is
no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.

 

[align=left]Input[/align]
There are multiple test cases.

Each test case contains several lines.

The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).

Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  

The input end with N=0, M=0.

 

[align=left]Output[/align]
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.

 

[align=left]Sample Input[/align]

2 0
8 3
2 4
4 5
7 8
0 0

 

[align=left]Sample Output[/align]

1.1667
2.3441

 

[align=left]Source[/align]
2012 ACM/ICPC Asia Regional Jinhua Online

 

[align=left]Recommend[/align]
zhoujiaqi2010   |   We have carefully selected several similar problems for you:  5746 5745 5744 5743 5742

 
题目:http://acm.hdu.edu.cn/showproblem.php?pid=4405

 

题意:飞行棋,从0到n,置骰子,置到几就往前走几步,前进中会有捷径,比如2和5连到一起了,那你走到2时可以直接跳到

5,如果5和8连到一起了,那你还可以继续跳到8,最后问跳到n时平均置几次骰子。也就是求期望。

 

全期望公式:http://zh.wikipedia.org/wiki/%E5%85%A8%E6%9C%9F%E6%9C%9B%E5%85%AC%E5%BC%8F

全概率公式:http://zh.wikipedia.org/wiki/%E5%85%A8%E6%A6%82%E7%8E%87%E5%85%AC%E5%BC%8F

概率期望学习:http://kicd.blog.163.com/blog/static/126961911200910168335852/

ACcode:

</pre><pre name="code" class="cpp">#include<cstdio>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
int n,m;
//N(1≤N≤100000) and M(0≤M≤1000).
#define maxN 100001
#define maxM 1001
int jump[maxN];
double dp[maxN];
int main()
{
int a,b;
while(scanf("%d%d",&n,&m)==2,n)
{
memset(dp,0,sizeof(dp));
memset(jump,-1,sizeof(jump));
for(int i=1;i<=m;i++)
{
scanf("%d%d",&a,&b);
jump[a]=b;
}
for(int i=n-1;i>=0;i--)
{
if(jump[i]!=-1)
{
dp[i]=dp[jump[i]];
}
else
{
for(int k=1;k<=6;k++)
{
if(i+k>n)break;
dp[i]+=dp[i+k];
}
dp[i]/=6;
dp[i]+=1;
}
}
printf("%.4lf\n",dp[0]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  概率DP 期望