您的位置:首页 > 其它

FatMouse' Trade hd 1009

2016-07-22 11:57 337 查看
Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All
integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3

7 2

4 3

5 2

20 3

25 18

24 15

15 10

-1 -1

Sample Output

13.333
31.500

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
double si;
double oi;
double p;
}s[1100];
int cmp(node x,node y)
{
return x.p>y.p;
}
int main()
{
int m,n,i;
int a[1100];
double sum;
while(scanf("%d%d",&m,&n)!=EOF)
{
sum=0;
if(m==-1&&n==-1) break;
for(i=0;i<n;i++)
scanf("%lf%lf",&s[i].si,&s[i].oi);
for(i=0;i<n;i++)
s[i].p=s[i].si/s[i].oi;
sort(s,s+n,cmp);
for(i=0;i<n;i++)
{
if(m>s[i].oi)
{
sum+=s[i].si;
m-=s[i].oi;
}
else
{
sum+=s[i].p*m;
break;
}

}
printf("%.3lf\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: