您的位置:首页 > 大数据 > 人工智能

E - Raising Modulo Numbers

2016-07-21 15:44 597 查看
Description

People are different. Some secretly read magazines full of interesting girls’ pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions Ai Bi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players’ experience it is possible to increase the difficulty by choosing higher numbers.

You should write a program that calculates the result and is able to find out who won the game.

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression

(A1B1+A2B2+ … +AHBH)mod M.

Sample Input

3

16

4

2 3

3 4

4 5

5 6

36123

1

2374859 3029382

17

1

3 18132

Sample Output

2

13195

13

本题用快速幂即可,注意两个数的和取模等于他们分别取模的和再取模。

代码如下:

#include <iostream>
using namespace std;
typedef long long LL;

LL qp(LL n, LL k, LL mod)
{
if(!k)
return 1;
LL tmp = qp(n, k/2, mod);

if(k&1)
{
//cout << tmp*tmp%mod << endl;
return (tmp*tmp%mod)*n%mod;
}
//cout << tmp*tmp%mod << endl;
return tmp*tmp%mod;
}

int main()
{
int z;
LL m;
int h;
LL a,b;
LL sum;
cin >> z;
while(z--)
{
sum = 0;
cin >> m >> h;
while(h--)
{
cin >> a >> b;
sum += qp(a,b,m);
}
cout << sum % m << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM 快速幂