您的位置:首页 > 大数据 > 人工智能

POJ 1995 Raising Modulo Numbers

2016-07-21 14:49 489 查看
题目:

Description

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment
was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions Ai Bi from all players
including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers.

You should write a program that calculates the result and is able to find out who won the game.

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be
divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression

(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132


Sample Output

2
13195
13


就是快速幂的问题,我是用递归来求幂的。

在函数int
mi(int m,int
a,int b)里面就要注意,因为a也可以很大,所以要做大量的模运算,因为只要有一次超了int范围,就全错了。

sum求和也是,每一步都要取模。

为了解决2个特别大的整数的乘法的问题,我还用了long long,最后取模之后又转化成int

代码:

#include<iostream>
using namespace std;

int mi(int m, int a, int b)	//求a^b % m
{
if (b == 0)return 1;
int t = mi(m, a, b / 2);
long long tt = t*t%m;
if (b % 2)
{
long long att = a*tt%m;
return int(att);
}
return int(tt);
}

int main()
{
int z;
cin >> z;
int m,h;
while (z--)
{
cin >> m >> h;
int a, b;
int sum = 0;
while (h--)
{
cin >> a >> b;
sum = (sum + mi(m, a%m, b)) % m;
}
cout << sum << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: