您的位置:首页 > 其它

【杭电oj】2803 - The MAX(水)

2016-07-19 15:56 288 查看
点击打开题目


The MAX

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2340    Accepted Submission(s): 1029


Problem Description

Giving N integers, V1, V2,,,,Vn, you should find the biggest value of F.



 

Input

Each test case contains a single integer N (1<=N<=100). The next line contains N integers, meaning the value of V1, V2....Vn.(1<= Vi <=10^8).The input is terminated by a set starting with N = 0. This set should not be processed.

 

Output

For each test case, output the biggest value of F you can find on a line.

 

Sample Input

2
1 2
0

 

Sample Output

4017

 

Source

HDU 2009-4 Programming Contest

题意看懂就挺水了。

代码如下:

#include <cstdio>
#include <algorithm>
using namespace std;
int main()
{
int n;
int v[100+11];
__int64 ans;
while (~scanf ("%d",&n) && n)
{
for (int i = 0 ; i < n ; i++)
scanf ("%d",&v[i]);
sort (v , v + n);
ans = 0;
for (int i = 0 ; i < n - 1 ; i++)
ans += v[i];
ans += (2010 - n) * (__int64)v[n-1];
printf ("%I64d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: