您的位置:首页 > 大数据 > 人工智能

hdu 1532 Drainage Ditches(最大流模板题)

2016-07-18 14:28 471 查看

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14721 Accepted Submission(s):
6968


[align=left]Problem Description[/align]
Every time it rains on Farmer John's fields, a pond
forms over Bessie's favorite clover patch. This means that the clover is covered
by water for awhile and takes quite a long time to regrow. Thus, Farmer John has
built a set of drainage ditches so that Bessie's clover patch is never covered
in water. Instead, the water is drained to a nearby stream. Being an ace
engineer, Farmer John has also installed regulators at the beginning of each
ditch, so he can control at what rate water flows into that ditch.
Farmer
John knows not only how many gallons of water each ditch can transport per
minute but also the exact layout of the ditches, which feed out of the pond and
into each other and stream in a potentially complex network.
Given all this
information, determine the maximum rate at which water can be transported out of
the pond and into the stream. For any given ditch, water flows in only one
direction, but there might be a way that water can flow in a circle.

[align=left]Input[/align]
The input includes several cases. For each case, the
first line contains two space-separated integers, N (0 <= N <= 200) and M
(2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is
the number of intersections points for those ditches. Intersection 1 is the
pond. Intersection point M is the stream. Each of the following N lines contains
three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the
intersections between which this ditch flows. Water will flow through this ditch
from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which
water will flow through the ditch.

[align=left]Output[/align]
For each case, output a single integer, the maximum
rate at which water may emptied from the pond.

[align=left]Sample Input[/align]

5 4

1 2 40

1 4 20

2 4 20
2 3 30

3 4 10

[align=left]Sample Output[/align]

50

[align=left]Source[/align]
USACO
93

[align=left]Recommend[/align]
lwg | We have carefully selected several similar
problems for you: 1533 3338 1569 3572 3416

第一次学习写最大流问题,一道模板题,思路还是比较清晰的,不过算法效率不是很高,还需要学习更快的方法。

题意:就是由于下大雨的时候约翰的农场就会被雨水给淹没,无奈下约翰不得不修建水沟,而且是网络水沟,并且聪明的约翰还控制了水的流速,本题就是让你求出最大流速,无疑要运用到求最大流了。题中N为水沟数,M为水沟的顶点,接下来Si,Ei,Ci分别是水沟的起点,终点以及其容量。求源点1到终点M的最大流速。注意重边

附上代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
#define INF 1e9
#define CL(a,b) memset(a,b,sizeof(a))
#define N 205

int n,m;
int mat

;
int pre
;
bool vis
;

int xmin(int a,int b)
{
return a>b?b:a;
}

bool BFS()
{
int cur;
queue<int> q;
CL(pre,0);
CL(vis,false);
vis[1]=true;   ///true表示这个点已作为起点搜索过了
q.push(1);
while(!q.empty())
{
cur=q.front();
q.pop();
if(cur == n) return true;  ///若搜到了终点,说明这是条增广路径,更新结果
for(int i=1; i<=n; i++)
if(!vis[i] && mat[cur][i]) ///是否存在通过的路径
{
q.push(i);
pre[i]=cur;
vis[i]=true;
}
}
return false;   ///若已经搜不到终点,则搜索结束
}

int max_flow()
{
int ans=0;
while(1)
{
if(!BFS()) return ans;
int Min = INF;
for(int i=n; i!=1; i=pre[i])
Min=xmin(Min,mat[pre[i]][i]);  ///找到最小的边,残留路径越小,则流量越大
for(int i=n; i!=1; i=pre[i])
{
mat[pre[i]][i]-=Min;   ///正向边
mat[i][pre[i]]+=Min;   ///反向边
}
ans+=Min;
}
}

int main()
{
int i,j;
while(~scanf("%d%d",&m,&n))
{
CL(mat,0);
int a,b,c;
while(m--)
{
scanf("%d%d%d",&a,&b,&c);
mat[a][b]+=c;    ///考虑重边情况,若有两条同样的边,流量为它们的和
}
printf("%d\n",max_flow());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: