您的位置:首页 > 其它

杭电-1002 A + B Problem II

2016-07-18 14:17 337 查看

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 313972    Accepted Submission(s): 60830


[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.

 

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211

 

[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

思路:
将大数看成字符串,然后对位相加,要注意判断开始为零的情况!
代码:
#include<stdio.h>
#include<string.h>
int max(int x,int y)
{
int w;
if(x>y)
w=x;
else
w=y;
return w;
}
int main()
{
int numa[1100],numb[1100],i,t;
int k=0;
char a[1100],b[1100];
scanf("%d",&t);
while(t--)
{
memset(numa,0,sizeof(numa));
memset(numb,0,sizeof(numb));
scanf("%s%s",a,b);
int lena=strlen(a);
int lenb=strlen(b);
for(i=0;i<lena;i++)
numa[lena-i-1]=a[i]-'0';
for(i=0;i<lenb;i++)
numb[lenb-i-1]=b[i]-'0';
int z=max(lena,lenb);
for(i=0;i<z;i++)
{
numa[i]=numa[i]+numb[i];
if(numa[i]>9)
{
numa[i]=numa[i]-10;
numa[i+1]++;
}
}
k++;
printf("Case %d:\n",k);
printf("%s + %s = ",a,b);
if(numa[z]==0)
{
for(i=z-1;i>=0;i--)
{
printf("%d",numa[i]);
}
printf("\n");
}
else
{
for(i=z;i>=0;i--)
{
printf("%d",numa[i]);
}
printf("\n");
}
if(t!=0)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: